Создаём таблицу в Excel 2007 – заполнение ячеек, формулы

Содержание
  1. Таблицы в формате EXCEL 2007
  2. Исходная таблица
  3. Действия с обычной таблицей
  4. Создание таблиц в формате EXCEL 2007
  5. Удаление таблиц в формате EXCEL 2007
  6. Добавление новых строк
  7. Удаление строк
  8. Данные итогов в таблице
  9. Присваивание имен таблицам
  10. Структурированные ссылки (ссылки на поля и значения таблицы в формулах)
  11. Копирование формул со структурированными ссылками
  12. Стили таблиц
  13. Умные Таблицы Excel – секреты эффективной работы
  14. Создание Таблицы Excel
  15. Структура и ссылки на Таблицу Excel
  16. Свойства Таблиц Excel
  17. Настройки Таблицы
  18. Ограничения Таблиц Excel
  19. Как работать в Excel с таблицами для чайников: пошаговая инструкция
  20. Как изменить границы ячеек
  21. Как вставить столбец или строку
  22. Пошаговое создание таблицы с формулами
  23. Как создать таблицу в Excel: пошаговая инструкция
  24. Как работать с таблицей в Excel
  25. Как создать таблицу в Excel: пошаговая инструкция
  26. Ручной режим
  27. Автоматический режим
  28. Сводная таблица
  29. Рекомендуемые сводные таблицы
  30. Готовые шаблоны в Excel 2016
  31. Оформление
  32. Создание заголовка
  33. Изменение высоты элементов
  34. Выравнивание текста
  35. Изменение стиля
  36. Как вставить новую строку или столбец
  37. Удаление элементов
  38. Заливка ячеек
  39. Формат элементов
  40. Формат содержимого
  41. Использование формул в таблицах
  42. Использование графики
  43. Экспорт в Word
  44. Онлайн-сервисы
  45. Способы печати
  46. Отличие версий продукции Майкрософт
  47. Ограничения и возможности разных версий
  48. Заключение
  49. инструкция

Таблицы в формате EXCEL 2007

Создаём таблицу в Excel 2007 - заполнение ячеек, формулы

Для упрощения управления логически связанными данными в EXCEL 2007 введен новый формат таблиц. Использование таблиц в формате EXCEL 2007 снижает вероятность ввода некорректных данных, упрощает вставку и удаление строк и столбцов, упрощает форматирование таблиц. 

Исходная таблица

Пусть имеется обычная таблица (диапазон ячеек), состоящая из 6 столбцов.

В столбце № (номер позиции), начиная со второй строки таблицы, имеется формула =A2+1, позволяющая производить автоматическую нумерацию строк. Для ускорения ввода значений в столбце Ед.изм. (единица измерения) с помощью Проверки данных создан Выпадающий (раскрывающийся) список.

В столбце Стоимость введена формула для подсчета стоимости товара (цена*количество) =E3*D3. Числовые значения в столбце отформатированы с отображением разделителей разрядов.

Действия с обычной таблицей

Чтобы показать преимущества таблиц в формате EXCEL 2007, сначала произведем основные действия с обычной таблицей.

Для начала добавим новую строку в таблицу, т.е. заполним данными строку 4 листа:

  • заполним значениями столбцы без формул (Наименование, Цена, Количество);
  • в столбцах Стоимость и № с помощью Маркера заполнения скопируем формулы в ячейки ниже;
  • чтобы в новой строке заработал Выпадающий список, в столбце Ед.изм. скопируем формат в ячейку ниже.  Для этого выделим ячейку С3, скопируем ее в Буфер обмена и, выделив ячейку ниже, через меню вставим Выпадающий список (либо, как на предыдущем шаге скопируем Маркером заполнения значение из ячейки С3 в С4, тем самым скопировав правило Проверки данных. Затем необходимо ввести значение Единицы измерения в новой строке).

Конечно, можно заранее скопировать формулы и форматы ячеек вниз на несколько строк – это ускорит заполнение таблицы.

Для добавления чрезстрочного выделения придется использовать Условное форматирование.

Теперь рассмотрим те же действия, но в таблице в формате EXCEL 2007.

Создание таблиц в формате EXCEL 2007

Выделим любую ячейку рассмотренной выше таблицы и выберем пункт меню  .

EXCEL автоматически определит, что в нашей таблице имеются заголовки столбцов. Если убрать галочку Таблица с заголовками, то для каждого столбца будут созданы заголовки Столбец1, Столбец2, …

СОВЕТ:
Избегайте заголовков в числовых форматах (например, «2009») и ссылок на них. При создании таблицы они будут преобразованы в текстовый формат. Формулы, использующие в качестве аргументов числовые заголовки, могут перестать работать.

После нажатия кнопки ОК:

  • к таблице будет автоматически применен стиль с чрезстрочным выделением;
  • в заголовке будет включен фильтр (чтобы его отключить выделите любую ячейку таблицы и нажмите CTRL+SHIFT+L, повторное нажатие включит фильтр);
  • станет доступным специальная вкладка в меню для работы с таблицами (), вкладка активна только когда выделена любая ячейка таблицы;
  • таблице будет присвоено Имя, которое можно посмотреть через конструктор таблиц или через Диспетчер имен ().

СОВЕТ:
Перед преобразованием таблицы в формат EXCEL 2007 убедитесь, что исходная таблица правильно структурирована. В статье Советы по построению таблиц изложены основные требования к «правильной» структуре таблицы.

Удаление таблиц в формате EXCEL 2007

Чтобы удалить таблицу вместе с данными, нужно выделить любой заголовок в таблице, нажать CTRL+A, затем клавишу DELETE (любо выделите любую ячейку с данными, дважды нажмите CTRL+A, затем клавишу DELETE). Другой способ удалить таблицу – удалить с листа все строки или столбцы, содержащие ячейки таблицы (удалить строки можно, например, выделив нужные строки за заголовки, вызвав правой клавишей мыши контекстное меню и выбрав пункт Удалить).

Чтобы сохранить данные таблицы можно преобразовать ее в обычный диапазон. Для этого выделите любую ячейку таблицы (Будет отображена вкладка Работа с таблицами, содержащая вкладку Конструктор) и через меню преобразуйте ее в обычный диапазон. Форматирование таблицы останется. Если форматирование также требуется удалить, то перед преобразованием в диапазон очистите стиль таблицы ().

Добавление новых строк

Теперь проделаем те же действия с таблицей в формате EXCEL 2007, которые мы осуществляли ранее с обычным диапазоном.

Начнем с заполнения со столбца Наименование (первый столбец без формул). После ввода значения, в таблице автоматически добавится новая строка.

Как видно из рисунка сверху, форматирование таблицы автоматически распространится на новую строку. Также в строку скопируются формулы в столбцах Стоимость и №. В столбце Ед.изм. станет доступен Выпадающий список с перечнем единиц измерений.

Для добавления новых строк в середине таблицы выделите любую ячейку в таблице, над которой нужно вставить новую строку. Правой клавишей мыши вызовите контекстное меню, выберите пункт меню Вставить (со стрелочкой), затем пункт Строки таблицы выше.

Удаление строк

Выделите одну или несколько ячеек в строках таблицы, которые требуется удалить. Щелкните правой кнопкой мыши, выберите в контекстном меню команду Удалить, а затем команду Строки таблицы. Будет удалена только строка таблицы, а не вся строка листа.

Аналогично можно удалить столбцы.

Данные итогов в таблице

Щелкните в любом месте таблицы. На вкладке Конструктор в группе Параметры стилей таблиц установите флажок Строка итогов.

В последней строке таблицы появится строка итогов, а в самой левой ячейке будет отображаться слово Итог.

В строке итогов щелкните ячейку в столбце, для которого нужно рассчитать значение итога, а затем щелкните появившуюся стрелку раскрывающегося списка.

В раскрывающемся списке выберите функцию, которая будет использоваться для расчета итогового значения. Формулы, которые можно использовать в строке итоговых данных, не ограничиваются формулами из списка.

Можно ввести любую нужную формулу в любой ячейке строки итогов.

После создания строки итогов добавление новых строк в таблицу затрудняется, т.к. строки перестают добавляться автоматически при добавлении новых значений (см. раздел Добавление строк). Но в этом нет ничего страшного: итоги можно отключить/ включить через меню.

Присваивание имен таблицам

При создании таблиц в формате EXCEL 2007, EXCEL присваивает имена таблиц автоматически: Таблица1, Таблица2 и т.д., но эти имена можно изменить (через конструктор таблиц: ), чтобы сделать их более выразительными.

Имя таблицы невозможно удалить (например, через Диспетчер имен). Пока существует таблица – будет определено и ее имя.

Структурированные ссылки (ссылки на поля и значения таблицы в формулах)

Теперь создадим формулу, в которой в качестве аргументов указан один из столбцов таблицы в формате EXCEL 2007 (формулу создадим вне строки итоги).

  • Введем в ячейку H1 часть формулы: =СУММ(
  • Мышкой выделим диапазон F2:F4 (весь столбец Стоимость без заголовка)

Но, вместо формулы =СУММ(F2:F4 мы увидим =СУММ(Таблица1[Стоимость]

Это и есть структурированная ссылка. В данном случае это ссылка на целый столбец. Если в таблицу будут добавляться новые строки, то формула =СУММ(Таблица1[Стоимость]) будет возвращать правильный результат с учетом значения новой строки. Таблица1 – это имя таблицы ().

Структурированные ссылки позволяют более простым и интуитивно понятным способом работать с данными таблиц при использовании формул, ссылающихся на столбцы и строки таблицы или на отдельные значения таблицы.

Рассмотрим другой пример суммирования столбца таблицы через ее Имя. В ячейке H2 введем =СУММ(Т (буква Т – первая буква имени таблицы). EXCEL предложит выбрать, начинающуюся на «Т», функцию или имя, определенное в этой книге (в том числе и имена таблиц).

Дважды щелкнув на имени таблицы, формула примет вид =СУММ(Таблица1. Теперь введем символ [ (открывающую квадратную скобку). EXCEL после ввода =СУММ(Таблица1[ предложит выбрать конкретное поле таблицы. Выберем поле Стоимость, дважды кликнув на него.

В формулу =СУММ(Таблица1[Стоимость введем символ ] (закрывающую квадратную скобку) и нажмем клавишу ENTER. В итоге получим сумму по столбцу Стоимость.

Ниже приведены другие виды структурированных ссылок:
Ссылка на заголовок столбца: =Таблица1[[#Заголовки];[Стоимость]] Ссылка на значение в той же строке =Таблица1[[#Эта строка];[Стоимость]]

Копирование формул со структурированными ссылками

Пусть имеется таблица со столбцами Стоимость и Стоимость с НДС. Предположим, что справа от таблицы требуется рассчитать общую стоимость и общую стоимость с НДС.

Сначала рассчитаем общую стоимость с помощью формулы =СУММ(Таблица1[Стоимость]). Формулу составим как показано в предыдущем разделе.

Теперь с помощью Маркера заполнения скопируем формулу вправо, она будет автоматически преобразована в формулу =СУММ(Таблица1[Стоимость с НДС])

Это удобно, но что будет если скопировать формулу дальше вправо? Формула будет автоматически преобразована в =СУММ(Таблица1[№]) Т.е. формула по кругу подставляет в формулу ссылки на столбцы таблицы. Т.е. структурированная ссылка похожа на относительную ссылку.

Теперь выделим ячейку J2 и нажмем комбинацию клавищ CTRL+R (скопировать формулу из ячейки слева). В отличие от Маркера заполнения мы получим формулу =СУММ(Таблица1[Стоимость]), а не =СУММ(Таблица1[Стоимость с НДС]). В этом случае структурированная ссылка похожа на абсолютную ссылку.

Теперь рассмотрим похожую таблицу и сделаем на основе ее данных небольшой отчет для расчета общей стоимости для каждого наименования фрукта.

В первой строке отчета (диапазон ячеек  I1:K2) содержатся наименования фруктов (без повторов), а во второй строке, в ячейке I2 формула =СУММЕСЛИ(Таблица1[Наименование];I1;Таблица1[Стоимость]) для нахождения общей стоимости фрукта Яблоки.

При копировании формулы с помощью Маркера заполнения в ячейку J2 (для нахождения общей стоимости фрукта Апельсины) формула станет неправильной =СУММЕСЛИ(Таблица1[Ед.изм.];J1;Таблица1[Стоимость с НДС]) (об этом см.

выше), копирование с помощью комбинации клавищ CTRL+R решает эту проблему. Но, если наименований больше, скажем 20, то как быстро скопировать формулу в другие ячейки? Для этого выделите нужные ячейки (включая ячейку с формулой) и поставьте курсор в Строку формул (см.

рисунок ниже), затем нажмите комбинацию клавищ CTRL+ENTER. Формула будет скопирована правильно.

Стили таблиц

Для таблиц, созданных в формате EXCEL 2007 () существует возможность использовать различные стили для придания таблицам определенного вида, в том числе и с чрезсрочным выделением. Выделите любую ячейку таблицы, далее нажмите и выберите подходящий стиль.

Источник: https://excel2.ru/articles/tablicy-v-formate-excel-2007

Умные Таблицы Excel – секреты эффективной работы

Создаём таблицу в Excel 2007 - заполнение ячеек, формулы

:  5 / 5

В MS Excel есть много потрясающих инструментов, о которых большинство пользователей не подозревают или сильно недооценивают. К таковым относятся Таблицы Excel. Вы скажете, что весь Excel – это электронная таблица? Нет. Рабочая область листа – это только множество ячеек. Некоторые из них заполнены, некоторые пустые, но по своей сути и функциональности все они одинаковы.

Таблица Excel – совсем другое. Это не просто диапазон данных, а цельный объект, у которого есть свое название, внутренняя структура, свойства и множество преимуществ по сравнению с обычным диапазоном ячеек. Также встречается под названием “умные таблицы”.

Создание Таблицы Excel

В наличии имеется обычный диапазон данных о продажах.

Чтобы преобразовать этот диапазон в Таблицу, следует выделить любую ячейку и перейти Вставка → Таблицы → Таблица

либо нажать горячую клавишу Ctrl+T.

Появится маленькое диалоговое окно, где можно поправить диапазон и указать, что в первой строке находятся заголовки столбцов.

Как правило, ничего не меняем. После нажатия Ок исходный диапазон превратится в Таблицу Excel.

Перед тем как перейти к свойствам Таблицы, посмотрим вначале, как ее видит сам Excel. Многое сразу прояснится.

Структура и ссылки на Таблицу Excel

Каждая Таблица имеет свое название. Это видно во вкладке Конструктор, которая появляется при выделении любой ячейки Таблицы. По умолчанию оно будет «Таблица1», «Таблица2» и т.д. 

Если в вашей книге Excel планируется несколько Таблиц, то имеет смысл придать им более говорящие названия. В дальнейшем это облегчит их использование (например, при работе в Power Pivot или Power Query). Я изменю название на «Отчет». Таблица «Отчет» видна в диспетчере имен Формулы → Определенные Имена → Диспетчер имен.

А также при наборе формулы вручную.

Но самое интересное заключается в том, что Эксель видит не только целую Таблицу, но и ее отдельные части: столбцы, заголовки, итоги и др. Ссылки при этом выглядят следующим образом.

=Отчет[#Все] – на всю Таблицу
=Отчет[#Данные] – только на данные (без строки заголовка)
=Отчет[#Заголовки] – только на первую строку заголовков
=Отчет[#Итоги] – на итоги
=Отчет[@] – на всю текущую строку (где вводится формула)
=Отчет[Продажи] – на весь столбец «Продажи»
=Отчет[@Продажи] – на ячейку из текущей строки столбца «Продажи»

Для написания ссылок совсем не обязательно запоминать все эти конструкции. При наборе формулы вручную все они видны в подсказках после выбора Таблицы и открытии квадратной скобки (в английской раскладке).

Выбираем нужное клавишей Tab. Не забываем закрыть все скобки, в том числе квадратную.

Если в какой-то ячейке написать формулу для суммирования по всему столбцу «Продажи»

=СУММ(D2:D8)

то она автоматически переделается в

=Отчет[Продажи]

Т.е. ссылка ведет не на конкретный диапазон, а на весь указанный столбец.

А теперь о том, как Таблицы облегчают жизнь и работу.

Свойства Таблиц Excel

1. Каждая Таблица имеет заголовки, которые обычно берутся из первой строки исходного диапазона.

2. Если Таблица большая, то при прокрутке вниз названия столбцов Таблицы заменяют названия столбцов листа.

Очень удобно, не нужно специально закреплять области.

3. В таблицу по умолчанию добавляется автофильтр, который можно отключить в настройках. Об этом чуть ниже.

4. Новые значения, записанные в первой пустой строке снизу, автоматически включаются в Таблицу Excel, поэтому они сразу попадают в формулу (или диаграмму), которая ссылается на некоторый столбец Таблицы.

Новые ячейки также форматируются под стиль таблицы, и заполняются формулами, если они есть в каком-то столбце. Короче, для продления Таблицы достаточно внести только значения. Форматы, формулы, ссылки – все добавится само.

5. Новые столбцы также автоматически включатся в Таблицу.

6. При внесении формулы в одну ячейку, она сразу копируется во все остальные. Не нужно вручную протягивать.

Помимо указанных свойств есть возможность сделать дополнительные настройки.

Настройки Таблицы

В контекстной вкладке Конструктор находятся дополнительные инструменты анализа и настроек.

С помощью галочек в группе Параметры стилей таблиц

можно внести следующие изменения.

– Удалить или добавить строку заголовков

– Добавить или удалить строку с итогами

– Сделать формат строк чередующимися

– Выделить жирным первый столбец

– Выделить жирным последний столбец

– Сделать чередующуюся заливку строк

– Убрать автофильтр, установленный по умолчанию

В видеоуроке ниже показано, как это работает в действии.

В группе Стили таблиц можно выбрать другой формат. По умолчанию он такой как на картинках выше, но это легко изменить, если надо.

В группе Инструменты можно создать сводную таблицу, удалить дубликаты, а также преобразовать в обычный диапазон.

Однако самое интересное – это создание срезов.

Срез – это фильтр, вынесенный в отдельный графический элемент. Нажимаем на кнопку Вставить срез, выбираем столбец (столбцы), по которому будем фильтровать,

и срез готов. В нем показаны все уникальные значения выбранного столбца.

Для фильтрации Таблицы следует выбрать интересующую категорию.

Если нужно выбрать несколько категорий, то удерживаем Ctrl или предварительно нажимаем кнопку в верхнем правом углу, слева от снятия фильтра.

Попробуйте сами, как здорово фильтровать срезами (кликается мышью). 

Для настройки самого среза на ленте также появляется контекстная вкладка Параметры. В ней можно изменить стиль, размеры кнопок, количество колонок и т.д. Там все понятно.

Ограничения Таблиц Excel

Несмотря на неоспоримые преимущества и колоссальные возможности, у Таблицы Excel есть недостатки.

1. Не работают представления. Это команда, которая запоминает некоторые настройки листа (фильтр, свернутые строки/столбцы и некоторые другие).

2. Текущую книгу нельзя выложить для совместного использования.

3. Невозможно вставить промежуточные итоги.

4. Не работают формулы массивов.

5. Нельзя объединять ячейки. Правда, и в обычном диапазоне этого делать не следует.

Однако на фоне свойств и возможностей Таблиц, эти недостатки практически не заметны.

Ниже можно посмотреть видеоурок о Таблицах Excel.

Множество других секретов Excel вы найдете в онлайн курсе.

Источник: https://statanaliz.info/excel/rabota-s-dannymi/157-umnye-tablitsy-excel-secrety

Как работать в Excel с таблицами для чайников: пошаговая инструкция

Создаём таблицу в Excel 2007 - заполнение ячеек, формулы

Программа Microsoft Excel удобна для составления таблиц и произведения расчетов. Рабочая область – это множество ячеек, которые можно заполнять данными. Впоследствии – форматировать, использовать для построения графиков, диаграмм, сводных отчетов.

Работа в Экселе с таблицами для начинающих пользователей может на первый взгляд показаться сложной. Она существенно отличается от принципов построения таблиц в Word. Но начнем мы с малого: с создания и форматирования таблицы. И в конце статьи вы уже будете понимать, что лучшего инструмента для создания таблиц, чем Excel не придумаешь.

Работа с таблицами в Excel для чайников не терпит спешки. Создать таблицу можно разными способами и для конкретных целей каждый способ обладает своими преимуществами. Поэтому сначала визуально оценим ситуацию.

Посмотрите внимательно на рабочий лист табличного процессора:

Это множество ячеек в столбцах и строках. По сути – таблица. Столбцы обозначены латинскими буквами. Строки – цифрами. Если вывести этот лист на печать, получим чистую страницу. Без всяких границ.

Сначала давайте научимся работать с ячейками, строками и столбцами.

Чтобы выделить весь столбец, щелкаем по его названию (латинской букве) левой кнопкой мыши.

Для выделения строки – по названию строки (по цифре).

Чтобы выделить несколько столбцов или строк, щелкаем левой кнопкой мыши по названию, держим и протаскиваем.

Для выделения столбца с помощью горячих клавиш ставим курсор в любую ячейку нужного столбца – нажимаем Ctrl + пробел. Для выделения строки – Shift + пробел.

Как изменить границы ячеек

Если информация при заполнении таблицы не помещается нужно изменить границы ячеек:

  1. Передвинуть вручную, зацепив границу ячейки левой кнопкой мыши.
  2. Когда длинное слово записано в ячейку, щелкнуть 2 раза по границе столбца / строки. Программа автоматически расширит границы.
  3. Если нужно сохранить ширину столбца, но увеличить высоту строки, воспользуемся кнопкой «Перенос текста» на панели инструментов.

Для изменения ширины столбцов и высоты строк сразу в определенном диапазоне выделяем область, увеличиваем 1 столбец /строку (передвигаем вручную) – автоматически изменится размер всех выделенных столбцов и строк.

Примечание. Чтобы вернуть прежний размер, можно нажать кнопку «Отмена» или комбинацию горячих клавиш CTRL+Z. Но она срабатывает тогда, когда делаешь сразу. Позже – не поможет.

Чтобы вернуть строки в исходные границы, открываем меню инструмента: «»-«Формат» и выбираем «Автоподбор высоты строки»

Для столбцов такой метод не актуален. Нажимаем «Формат» – «Ширина по умолчанию». Запоминаем эту цифру. Выделяем любую ячейку в столбце, границы которого необходимо «вернуть». Снова «Формат» – «Ширина столбца» – вводим заданный программой показатель (как правило это 8,43 – количество символов шрифта Calibri с размером в 11 пунктов). ОК.

Как вставить столбец или строку

Выделяем столбец /строку правее /ниже того места, где нужно вставить новый диапазон. То есть столбец появится слева от выделенной ячейки. А строка – выше.

Нажимаем правой кнопкой мыши – выбираем в выпадающем меню «Вставить» (или жмем комбинацию горячих клавиш CTRL+SHIFT+”=”).

Отмечаем «столбец» и жмем ОК.

Совет. Для быстрой вставки столбца нужно выделить столбец в желаемом месте и нажать CTRL+SHIFT+”=”.

Все эти навыки пригодятся при составлении таблицы в программе Excel. Нам придется расширять границы, добавлять строки /столбцы в процессе работы.

Пошаговое создание таблицы с формулами

  1. Заполняем вручную шапку – названия столбцов. Вносим данные – заполняем строки. Сразу применяем на практике полученные знания – расширяем границы столбцов, «подбираем» высоту для строк.
  2. Чтобы заполнить графу «Стоимость», ставим курсор в первую ячейку. Пишем «=».

    Таким образом, мы сигнализируем программе Excel: здесь будет формула. Выделяем ячейку В2 (с первой ценой). Вводим знак умножения (*). Выделяем ячейку С2 (с количеством). Жмем ВВОД.

  3. Когда мы подведем курсор к ячейке с формулой, в правом нижнем углу сформируется крестик.

    Он указываем на маркер автозаполнения. Цепляем его левой кнопкой мыши и ведем до конца столбца. Формула скопируется во все ячейки.

  4. Обозначим границы нашей таблицы. Выделяем диапазон с данными. Нажимаем кнопку: «»-«Границы» (на главной странице в меню «Шрифт»). И выбираем «Все границы».

Теперь при печати границы столбцов и строк будут видны.

С помощью меню «Шрифт» можно форматировать данные таблицы Excel, как в программе Word.

Поменяйте, к примеру, размер шрифта, сделайте шапку «жирным». Можно установить текст по центру, назначить переносы и т.д.

Как создать таблицу в Excel: пошаговая инструкция

Простейший способ создания таблиц уже известен. Но в Excel есть более удобный вариант (в плане последующего форматирования, работы с данными).

Сделаем «умную» (динамическую) таблицу:

  1. Переходим на вкладку «Вставка» – инструмент «Таблица» (или нажмите комбинацию горячих клавиш CTRL+T).
  2. В открывшемся диалоговом окне указываем диапазон для данных. Отмечаем, что таблица с подзаголовками. Жмем ОК. Ничего страшного, если сразу не угадаете диапазон. «Умная таблица» подвижная, динамическая.

Примечание. Можно пойти по другому пути – сначала выделить диапазон ячеек, а потом нажать кнопку «Таблица».

Теперь вносите необходимые данные в готовый каркас. Если потребуется дополнительный столбец, ставим курсор в предназначенную для названия ячейку. Вписываем наименование и нажимаем ВВОД. Диапазон автоматически расширится.

Если необходимо увеличить количество строк, зацепляем в нижнем правом углу за маркер автозаполнения и протягиваем вниз.

Как работать с таблицей в Excel

С выходом новых версий программы работа в Эксель с таблицами стала интересней и динамичней. Когда на листе сформирована умная таблица, становится доступным инструмент «Работа с таблицами» – «Конструктор».

Здесь мы можем дать имя таблице, изменить размер.

Доступны различные стили, возможность преобразовать таблицу в обычный диапазон или сводный отчет.

Возможности динамических электронных таблиц MS Excel огромны. Начнем с элементарных навыков ввода данных и автозаполнения:

  1. Выделяем ячейку, щелкнув по ней левой кнопкой мыши. Вводим текстовое /числовое значение. Жмем ВВОД. Если необходимо изменить значение, снова ставим курсор в эту же ячейку и вводим новые данные.
  2. При введении повторяющихся значений Excel будет распознавать их. Достаточно набрать на клавиатуре несколько символов и нажать Enter.
  3. Чтобы применить в умной таблице формулу для всего столбца, достаточно ввести ее в одну первую ячейку этого столбца. Программа скопирует в остальные ячейки автоматически.
  4. Для подсчета итогов выделяем столбец со значениями плюс пустая ячейка для будущего итога и нажимаем кнопку «Сумма» (группа инструментов «Редактирование» на закладке «» или нажмите комбинацию горячих клавиш ALT+”=”).

Если нажать на стрелочку справа каждого подзаголовка шапки, то мы получим доступ к дополнительным инструментам для работы с данными таблицы.

Иногда пользователю приходится работать с огромными таблицами. Чтобы посмотреть итоги, нужно пролистать не одну тысячу строк. Удалить строки – не вариант (данные впоследствии понадобятся). Но можно скрыть. Для этой цели воспользуйтесь числовыми фильтрами (картинка выше). Убираете галочки напротив тех значений, которые должны быть спрятаны.

Источник: https://exceltable.com/sozdat-tablicu/kak-rabotat-v-excel-s-tablicami

Как создать таблицу в Excel: пошаговая инструкция

Создаём таблицу в Excel 2007 - заполнение ячеек, формулы

Программа Microsoft Excel – очень мощный инструмент, благодаря которому можно создать большие таблицы с красивым оформлением и обилием различных формул. Работа с информацией облегчается именно из-за динамики, которая отсутствует в приложении Word.

В данной статье будет показано, как создать таблицу в Excel. Благодаря пошаговой инструкции с этим сможет разобраться даже «чайник». Поначалу начинающим пользователям это может показаться сложным. Но на самом деле, при постоянной работе в программе «Эксель» вы станете профессионалом и сможете оказывать помощь другим.

План обучения будет прост:

  • сначала рассматриваем различные методы создания таблиц;
  • затем занимаемся оформлением, чтобы информация была максимально наглядной и понятной.

Ручной режим

Данный метод самый простой. Делается это следующим образом.

  1. Открыв пустой лист, вы увидите большое количество одинаковых ячеек.
  1. Выделите любое количество строк и столбцов.
  1. После этого перейдите на вкладку «». Нажмите на иконку «Границы». Затем выберите пункт «Все».
  1. Сразу после этого у вас появится обычная элементарная табличка.

Теперь можете приступать к заполнению данных.

Существует и другой способ ручного рисования таблицы.

  1. Снова нажмите на иконку «Границы». Но на этот раз выберите пункт «Нарисовать сетку».
  1. Сразу после этого у вас изменится внешний вид курсора.
  1. Сделайте левый клик мыши и перетаскивайте указатель в другое положение. В результате этого будет нарисована новая сетка. Верхний левый угол – начальное положение курсора. Правый нижний угол – конечное.

Размеры могут быть любыми. Таблица будет создаваться, пока вы не отпустите палец с кнопки мыши.

Автоматический режим

Если вы не хотите «работать руками», всегда можно воспользоваться готовыми функциями. Для этого необходимо сделать следующее.

  1. Перейдите на вкладку «Вставка». Нажмите на кнопку «Таблицы» и выберите последний пункт.

Обратите внимание на то, что нам подсказывают о горячих клавишах. В дальнейшем для автоматического создания можно использовать сочетание кнопок Ctrl+T.

  1. Сразу после этого у вас появится окно, в котором нужно указать диапазон будущей таблицы.
  1. Для этого достаточно просто выделить любую область – координаты подставятся автоматом.
  1. Как только вы отпустите курсор, окно примет исходный вид. Нажмите на кнопку «OK».
  1. В результате этого будет создана красивая таблица с чередующимися линиями.
  1. Для того чтобы изменить название столбца, достаточно кликнуть на него. После этого начать редактирование можно прямо в этой ячейке или в строке формул.

Дальше можете делать, что душе угодно.

Сводная таблица

Данный тип представления информации служит для ее обобщения и последующего анализа. Для создания такого элемента нужно сделать следующие шаги.

  1. Сначала делаем таблицу и заполняем её какими-нибудь данными. Как это сделать, описано выше.
  1. Теперь заходим в главное меню «Вставка». Далее выбираем нужный нам вариант.
  1. Сразу после этого у вас появится новое окно.
  1. Кликните на первую строчку (поле ввода нужно сделать активным). Только после этого выделяем все ячейки.
  1. Затем нажимаем на кнопку «OK».
  1. В результате этого у вас появится новая боковая панель, где нужно настроить будущую таблицу.
  1. На этом этапе необходимо перенести поля в нужные категории. Столбцами у нас будут месяцы, строками – назначение затрат, а значениями – сумма денег.

Для переноса надо кликнуть левой кнопкой мыши на любое поле и не отпуская пальца перетащить курсор в нужное место.

Только после этого (иконка курсора изменит внешний вид) палец можно отпустить.

  1. В результате этих действий у вас появится новая красивая таблица, в которой всё будет подсчитано автоматически. Самое главное, что появятся новые ячейки – «Общий итог».

Вы можете сами указывать поля, которые интересны для анализа данных.

Например, в данном случае мы смогли посчитать, сколько у нас уходит денег на каждый вид расходов в каждом месяце. При этом узнали суммарный расход как по категории, так и по временному интервалу.

Рекомендуемые сводные таблицы

Иногда не получается правильно подобрать поля для столбцов и строк. И в итоге ничего путного не выходит. Для таких случаев разработчики Microsoft подготовили свои варианты анализа данных.

Работает это очень просто.

  1. Первым делом выделяем нужную нам информацию.
  1. После этого выбираем соответствующий пункт меню.
  1. В результате программа сама проанализирует содержимое ячеек и предложит несколько вариантов.
  1. Кликнув на любой из предложенных вариантов и нажав на кнопку «OK», всё будет создано автоматически.
  1. В случае примера, мы получили сумму общих затрат, без учета месяцев.

Готовые шаблоны в Excel 2016

Для особо ленивых данная программа позволяет создавать по-настоящему «крутые» таблицы всего одним кликом.

При запуске Экселя вам на выбор предлагаются следующие варианты:

  • открыть последние файлы, с которыми вы работали ранее;
  • создать новую пустую книгу;
  • посмотреть учебник с подробной информацией о возможностях данного ПО;
  • выбрать какой-нибудь готовый шаблон по умолчанию;
  • продолжить поиск в интернете, если ни один из предложенных дизайнов вам не понравился;
  • войти под своей учетной записью Microsoft.

Нас интересуют именно готовые варианты. Если вы прокрутите немного вниз, то увидите, что их очень много. А ведь это шаблоны по умолчанию. Представьте, сколько можно скачать их в интернете.

Кликаем на какой-нибудь понравившийся вариант.

Нажимаем на кнопку «Создать».

В результате этого вы получаете готовый вариант очень большой и сложной таблицы.

Оформление

Внешний вид – это один из важнейших параметров. Очень важно сделать акцент на каких-нибудь элементах. Например, шапка, заголовок и так далее. Всё зависит от конкретного случая.

Рассмотрим вкратце основные манипуляции с ячейками.

Создание заголовка

В качестве примера будем использовать простую таблицу.

  1. Сначала переходим на вкладку «» и нажимаем на пункт меню «Вставить строки на лист».
  1. Выделяем появившуюся строчку и нажимаем на пункт меню «Объединить ячейки».
  1. Далее пишем любой заголовок.

Изменение высоты элементов

Наш заголовок по размеру одинаковый с шапкой. А это не очень красиво. Кроме того, он смотрится невзрачно. Для того чтобы это исправить, нужно перенести курсор на границу 1 и 2 строки. После того, как его внешний вид изменится, сделайте левый клик мыши и потяните вниз.

В результате этого высота строки будет больше.

Выравнивание текста

Наш заголовок расположен внизу ячейки и прилип к шапке. Для того чтобы это исправить, необходимо воспользоваться кнопками выравнивания. Вы можете изменить положение текста как по вертикали, так и по горизонтали.

Кликаем на кнопку «По середине» и получаем желанный результат.

Теперь заголовок смотрится куда лучше.

Изменение стиля

Также рекомендуется изменить шрифт и увеличить кегль (размер по вертикали). Сделать это можно вручную при помощи панели инструментов.

Или же использовать готовые стили. Для этого сначала выделяем строку. Затем через меню выбираем любой из предложенных вариантов оформления.

Эффект будет очень красивым.

Как вставить новую строку или столбец

Для того чтобы изменить количество элементов в таблице, можно воспользоваться кнопкой «Вставить».

Вы можете добавить:

  • ячейки;
  • строки;
  • столбцы;
  • целый лист.

Удаление элементов

Уничтожить ячейку или что-нибудь еще можно точно так же. Для этого есть своя кнопка.

Заливка ячеек

Если вы хотите выделить какую-нибудь колонку или строчку, для этого нужно использовать инструмент заливка.

Благодаря ему вы сможете поменять цвет любых ячеек, которые были выделены ранее.

Формат элементов

При желании можно сделать с таблицей что угодно. Для этого достаточно нажать на кнопку «Формат».

В результате этого вы сумеете:

  • вручную или автоматически изменить высоту строк;
  • вручную или автоматически изменить ширину столбцов;
  • скрыть или отобразить ячейки;
  • переименовать лист;
  • изменить цвет ярлыка;
  • защитить лист;
  • блокировать элемент;
  • указать формат ячеек.

Формат содержимого

Если нажать на последний из вышеописанных пунктов, то появится следующее:

Благодаря этому инструменту можно:

  • изменить формат отображаемых данных;
  • указать выравнивание;
  • изменить границы таблицы;

Использование формул в таблицах

Именно благодаря возможности использовать функции автоподсчёта (умножение, сложение и так далее), Microsoft Excel и стал мощным инструментом.

Полную информацию о формулах в Экзеле лучше всего посмотреть на официальной странице справки.

Кроме этого, рекомендуется ознакомиться с описанием всех функций.

Рассмотрим самую простую операцию – умножение ячеек.

  1. Для начала подготовим поле для экспериментов.
  1. Сделайте активной первую ячейку, в которой нужно вывести результат.
  1. Введите там следующую команду.

=C3*D3

  1. Теперь нажмите на клавишу Enter. После этого наведите курсор на правый нижний угол этой ячейки до тех пор, пока не изменится его внешний вид. Затем зажмите пальцем левый клик мыши и потяните вниз до последней строки.
  1. В результате автоподстановки формула попадёт во все ячейки.

Значения в колонке «Общая стоимость» будут зависеть от полей «Количество» и «Стоимость 1 кг». Это и есть прелесть динамики.

Кроме этого, можно использовать готовые функции для расчётов. Попробуем посчитать сумму последней графы.

  1. Сначала выделяем значения. Затем нажимаем на кнопку «Автосуммы», которая расположена на вкладке «».
  1. В результате этого ниже появится общая сумма всех чисел.

Использование графики

Иногда в ячейках вместо текста используют фотографии. Сделать это очень легко.

Выбираем пустой элемент. Переходим на вкладку «Вставка». Выбираем раздел «Иллюстрации». Кликаем на пункт «Рисунки».

  1. Указываем файл и кликаем на кнопку «Вставить».
  1. Результат вас не разочарует. Смотрится очень красиво (в зависимости от подобранного рисунка).

Экспорт в Word

Для того чтобы скопировать данные в «вордовский» документ, достаточно сделать пару простых действий.

  1. Нажмите на горячие клавиши Ctrl+C.
  2. Откройте документ
  3. Теперь используем кнопки Ctrl+V.
  4. Итог будет следующим.

Онлайн-сервисы

Для тех, кто хочет работать в «реальном режиме» и делиться информацией с друзьями или коллегами по работе, существует отличный инструмент «Google Таблицы».

Используя этот сервис, вы сможете получить доступ к своим документам с любого устройства: компьютер, ноутбук, телефон или планшет.

Способы печати

Распечатка документов Word, как правило, задача несложная. Но с таблицами в Excel всё иначе. Самая большая проблема заключается в том, что «на глаз» сложно определить границы печати. И очень часто в принтере появляются практически пустые листы, на которых находится всего 1-2 строки таблицы.

Такие распечатки неудобны для восприятия. Намного лучше, когда вся информация находится на одном листе и никуда за границы не выходит. В связи с этим разработчики из Microsoft добавили функцию просмотра документов. Давайте рассмотрим, как этим пользоваться.

  1. Открываем документ. Он выглядит вполне обычно.
  1. Далее нажмите на горячие клавиши Ctrl+P. В появившемся окне мы видим, что информация не помещается на один лист. У нас исчезла графа «Общая стоимость». Кроме того, внизу нам подсказывают, что при печати будет использовано 2 страницы.

В версии 2007 года, для этого нужно было нажать на кнопку «Просмотр».

  1. Для отмены нажимаем горячую клавишу Esc. В результате появится вертикальная пунктирная линия, которая показывает границы печати.

Увеличить пространство при печати можно следующим образом.

  1. Первым делом уменьшаем поля. Для этого переходим на вкладку «Разметка страницы». Кликаем на кнопку «Поля» и выбираем самый «Узкий» вариант.
  1. После этого уменьшаем ширину столбцов, пока пунктирная линия не окажется за пределами последней колонки. Как это сделать, было описано выше.

Уменьшать нужно в разумных пределах, чтобы не страдала читабельность текста.

  1. Снова нажимаем на Ctrl+P. Теперь мы видим, что информация помещается на один лист.

Отличие версий продукции Майкрософт

Стоит понимать, что Эксель 2003 года уже давно морально устарел. Там отсутствует огромное количество современных функций и возможностей. Кроме этого, внешний вид различных объектов (графики, диаграммы и так далее) сильно уступает современным требованиям.

Пример рабочей области Excel 2003.

В современных 2007, 2010, 2013, а тем более 2016 версиях всё намного «круче».

Многие пункты меню находятся в разных разделах. Некоторые из них вовсе изменили своё название. Например, привычные нам «Формулы», в далёком 2003 назывались «Функциями». И они занимали не так уж много места.

Сейчас же для них отведена целая вкладка.

Ограничения и возможности разных версий

На официальном сайте компании Microsoft можно найти онлайн справку, в которой приводятся все технические характеристики создаваемых книг.

Пример самых основных параметров.

Этот список довольно длинный. Поэтому стоит перейти по ссылке и ознакомиться с остальными.

Обратите внимание, что версию 2003 года даже не рассматривают, так как её поддержка прекращена.

Но в некоторых бюджетных организациях этот офисный пакет используется и по сей день.

Заключение

В данной статье были рассмотрены различные способы создания и представления таблиц. Особое внимание было уделено приданию красивого внешнего вида. Не стоит переусердствовать в этом плане, поскольку яркие цвета и многообразие шрифтов будут отпугивать пользователя, который пытается ознакомиться с содержимым таблицы.

инструкция

Тем, у кого остались какие-нибудь вопросы, ниже прилагается видеоролик, в котором прилагаются дополнительные комментарии к описанным выше инструкциям.

Источник: https://os-helper.ru/excel/sozdaem-tablicu.html

HelpIcs
Добавить комментарий