Работаем в Экселе – построение и заполнение таблиц

Содержание
  1. Как создать таблицу в Excel: пошаговая инструкция
  2. Ручной режим
  3. Автоматический режим
  4. Сводная таблица
  5. Рекомендуемые сводные таблицы
  6. Готовые шаблоны в Excel 2016
  7. Оформление
  8. Создание заголовка
  9. Изменение высоты элементов
  10. Выравнивание текста
  11. Изменение стиля
  12. Как вставить новую строку или столбец
  13. Удаление элементов
  14. Заливка ячеек
  15. Формат элементов
  16. Формат содержимого
  17. Использование формул в таблицах
  18. Использование графики
  19. Экспорт в Word
  20. Онлайн-сервисы
  21. Способы печати
  22. Отличие версий продукции Майкрософт
  23. Ограничения и возможности разных версий
  24. Заключение
  25. инструкция
  26. Умные Таблицы Excel – секреты эффективной работы
  27. Создание Таблицы Excel
  28. Структура и ссылки на Таблицу Excel
  29. Свойства Таблиц Excel
  30. Настройки Таблицы
  31. Ограничения Таблиц Excel
  32. Как работать в Excel с таблицами для чайников: пошаговая инструкция
  33. Как изменить границы ячеек
  34. Как вставить столбец или строку
  35. Пошаговое создание таблицы с формулами
  36. Как создать таблицу в Excel: пошаговая инструкция
  37. Как работать с таблицей в Excel
  38. Как сделать таблицу в Excel. Пошаговая инструкция
  39. Как работать в Excel с таблицами. Пошаговая инструкция
  40. 1. Выделите область ячеек для создания таблицы
  41. 2. Нажмите кнопку “Таблица” на панели быстрого доступа
  42. 3. Выберите диапазон ячеек
  43. 4. Таблица готова. Заполняйте данными!
  44. Форматирование таблицы в Excel
  45. Как добавить строку или столбец в таблице Excel
  46. Как отсортировать таблицу в Excel
  47. Как отфильтровать данные в таблице Excel
  48. Как посчитать сумму в таблице Excel
  49. Как в Excel закрепить шапку таблицы
  50. Как перевернуть таблицу в Excel
  51. Сводные таблицы в Excel
  52. Немного теории
  53. Пример создания сводной таблицы Excel – алгоритм для чайников
  54. Обновление данных в сводной таблице в Excel
  55. Как в сводную таблицу Excel добавить столбец или таблицу
  56. Как сделать сводную таблицу в Excel из нескольких листов
  57. Изменение структуры отчёта

Как создать таблицу в Excel: пошаговая инструкция

Работаем в Экселе - построение и заполнение таблиц

Программа Microsoft Excel – очень мощный инструмент, благодаря которому можно создать большие таблицы с красивым оформлением и обилием различных формул. Работа с информацией облегчается именно из-за динамики, которая отсутствует в приложении Word.

В данной статье будет показано, как создать таблицу в Excel. Благодаря пошаговой инструкции с этим сможет разобраться даже «чайник». Поначалу начинающим пользователям это может показаться сложным. Но на самом деле, при постоянной работе в программе «Эксель» вы станете профессионалом и сможете оказывать помощь другим.

План обучения будет прост:

  • сначала рассматриваем различные методы создания таблиц;
  • затем занимаемся оформлением, чтобы информация была максимально наглядной и понятной.

Ручной режим

Данный метод самый простой. Делается это следующим образом.

  1. Открыв пустой лист, вы увидите большое количество одинаковых ячеек.
  1. Выделите любое количество строк и столбцов.
  1. После этого перейдите на вкладку «». Нажмите на иконку «Границы». Затем выберите пункт «Все».
  1. Сразу после этого у вас появится обычная элементарная табличка.

Теперь можете приступать к заполнению данных.

Существует и другой способ ручного рисования таблицы.

  1. Снова нажмите на иконку «Границы». Но на этот раз выберите пункт «Нарисовать сетку».
  1. Сразу после этого у вас изменится внешний вид курсора.
  1. Сделайте левый клик мыши и перетаскивайте указатель в другое положение. В результате этого будет нарисована новая сетка. Верхний левый угол – начальное положение курсора. Правый нижний угол – конечное.

Размеры могут быть любыми. Таблица будет создаваться, пока вы не отпустите палец с кнопки мыши.

Автоматический режим

Если вы не хотите «работать руками», всегда можно воспользоваться готовыми функциями. Для этого необходимо сделать следующее.

  1. Перейдите на вкладку «Вставка». Нажмите на кнопку «Таблицы» и выберите последний пункт.

Обратите внимание на то, что нам подсказывают о горячих клавишах. В дальнейшем для автоматического создания можно использовать сочетание кнопок Ctrl+T.

  1. Сразу после этого у вас появится окно, в котором нужно указать диапазон будущей таблицы.
  1. Для этого достаточно просто выделить любую область – координаты подставятся автоматом.
  1. Как только вы отпустите курсор, окно примет исходный вид. Нажмите на кнопку «OK».
  1. В результате этого будет создана красивая таблица с чередующимися линиями.
  1. Для того чтобы изменить название столбца, достаточно кликнуть на него. После этого начать редактирование можно прямо в этой ячейке или в строке формул.

Дальше можете делать, что душе угодно.

Сводная таблица

Данный тип представления информации служит для ее обобщения и последующего анализа. Для создания такого элемента нужно сделать следующие шаги.

  1. Сначала делаем таблицу и заполняем её какими-нибудь данными. Как это сделать, описано выше.
  1. Теперь заходим в главное меню «Вставка». Далее выбираем нужный нам вариант.
  1. Сразу после этого у вас появится новое окно.
  1. Кликните на первую строчку (поле ввода нужно сделать активным). Только после этого выделяем все ячейки.
  1. Затем нажимаем на кнопку «OK».
  1. В результате этого у вас появится новая боковая панель, где нужно настроить будущую таблицу.
  1. На этом этапе необходимо перенести поля в нужные категории. Столбцами у нас будут месяцы, строками – назначение затрат, а значениями – сумма денег.

Для переноса надо кликнуть левой кнопкой мыши на любое поле и не отпуская пальца перетащить курсор в нужное место.

Только после этого (иконка курсора изменит внешний вид) палец можно отпустить.

  1. В результате этих действий у вас появится новая красивая таблица, в которой всё будет подсчитано автоматически. Самое главное, что появятся новые ячейки – «Общий итог».

Вы можете сами указывать поля, которые интересны для анализа данных.

Например, в данном случае мы смогли посчитать, сколько у нас уходит денег на каждый вид расходов в каждом месяце. При этом узнали суммарный расход как по категории, так и по временному интервалу.

Рекомендуемые сводные таблицы

Иногда не получается правильно подобрать поля для столбцов и строк. И в итоге ничего путного не выходит. Для таких случаев разработчики Microsoft подготовили свои варианты анализа данных.

Работает это очень просто.

  1. Первым делом выделяем нужную нам информацию.
  1. После этого выбираем соответствующий пункт меню.
  1. В результате программа сама проанализирует содержимое ячеек и предложит несколько вариантов.
  1. Кликнув на любой из предложенных вариантов и нажав на кнопку «OK», всё будет создано автоматически.
  1. В случае примера, мы получили сумму общих затрат, без учета месяцев.

Готовые шаблоны в Excel 2016

Для особо ленивых данная программа позволяет создавать по-настоящему «крутые» таблицы всего одним кликом.

При запуске Экселя вам на выбор предлагаются следующие варианты:

  • открыть последние файлы, с которыми вы работали ранее;
  • создать новую пустую книгу;
  • посмотреть учебник с подробной информацией о возможностях данного ПО;
  • выбрать какой-нибудь готовый шаблон по умолчанию;
  • продолжить поиск в интернете, если ни один из предложенных дизайнов вам не понравился;
  • войти под своей учетной записью Microsoft.

Нас интересуют именно готовые варианты. Если вы прокрутите немного вниз, то увидите, что их очень много. А ведь это шаблоны по умолчанию. Представьте, сколько можно скачать их в интернете.

Кликаем на какой-нибудь понравившийся вариант.

Нажимаем на кнопку «Создать».

В результате этого вы получаете готовый вариант очень большой и сложной таблицы.

Оформление

Внешний вид – это один из важнейших параметров. Очень важно сделать акцент на каких-нибудь элементах. Например, шапка, заголовок и так далее. Всё зависит от конкретного случая.

Рассмотрим вкратце основные манипуляции с ячейками.

Создание заголовка

В качестве примера будем использовать простую таблицу.

  1. Сначала переходим на вкладку «» и нажимаем на пункт меню «Вставить строки на лист».
  1. Выделяем появившуюся строчку и нажимаем на пункт меню «Объединить ячейки».
  1. Далее пишем любой заголовок.

Изменение высоты элементов

Наш заголовок по размеру одинаковый с шапкой. А это не очень красиво. Кроме того, он смотрится невзрачно. Для того чтобы это исправить, нужно перенести курсор на границу 1 и 2 строки. После того, как его внешний вид изменится, сделайте левый клик мыши и потяните вниз.

В результате этого высота строки будет больше.

Выравнивание текста

Наш заголовок расположен внизу ячейки и прилип к шапке. Для того чтобы это исправить, необходимо воспользоваться кнопками выравнивания. Вы можете изменить положение текста как по вертикали, так и по горизонтали.

Кликаем на кнопку «По середине» и получаем желанный результат.

Теперь заголовок смотрится куда лучше.

Изменение стиля

Также рекомендуется изменить шрифт и увеличить кегль (размер по вертикали). Сделать это можно вручную при помощи панели инструментов.

Или же использовать готовые стили. Для этого сначала выделяем строку. Затем через меню выбираем любой из предложенных вариантов оформления.

Эффект будет очень красивым.

Как вставить новую строку или столбец

Для того чтобы изменить количество элементов в таблице, можно воспользоваться кнопкой «Вставить».

Вы можете добавить:

  • ячейки;
  • строки;
  • столбцы;
  • целый лист.

Удаление элементов

Уничтожить ячейку или что-нибудь еще можно точно так же. Для этого есть своя кнопка.

Заливка ячеек

Если вы хотите выделить какую-нибудь колонку или строчку, для этого нужно использовать инструмент заливка.

Благодаря ему вы сможете поменять цвет любых ячеек, которые были выделены ранее.

Формат элементов

При желании можно сделать с таблицей что угодно. Для этого достаточно нажать на кнопку «Формат».

В результате этого вы сумеете:

  • вручную или автоматически изменить высоту строк;
  • вручную или автоматически изменить ширину столбцов;
  • скрыть или отобразить ячейки;
  • переименовать лист;
  • изменить цвет ярлыка;
  • защитить лист;
  • блокировать элемент;
  • указать формат ячеек.

Формат содержимого

Если нажать на последний из вышеописанных пунктов, то появится следующее:

Благодаря этому инструменту можно:

  • изменить формат отображаемых данных;
  • указать выравнивание;
  • изменить границы таблицы;

Использование формул в таблицах

Именно благодаря возможности использовать функции автоподсчёта (умножение, сложение и так далее), Microsoft Excel и стал мощным инструментом.

Полную информацию о формулах в Экзеле лучше всего посмотреть на официальной странице справки.

Кроме этого, рекомендуется ознакомиться с описанием всех функций.

Рассмотрим самую простую операцию – умножение ячеек.

  1. Для начала подготовим поле для экспериментов.
  1. Сделайте активной первую ячейку, в которой нужно вывести результат.
  1. Введите там следующую команду.

=C3*D3

  1. Теперь нажмите на клавишу Enter. После этого наведите курсор на правый нижний угол этой ячейки до тех пор, пока не изменится его внешний вид. Затем зажмите пальцем левый клик мыши и потяните вниз до последней строки.
  1. В результате автоподстановки формула попадёт во все ячейки.

Значения в колонке «Общая стоимость» будут зависеть от полей «Количество» и «Стоимость 1 кг». Это и есть прелесть динамики.

Кроме этого, можно использовать готовые функции для расчётов. Попробуем посчитать сумму последней графы.

  1. Сначала выделяем значения. Затем нажимаем на кнопку «Автосуммы», которая расположена на вкладке «».
  1. В результате этого ниже появится общая сумма всех чисел.

Использование графики

Иногда в ячейках вместо текста используют фотографии. Сделать это очень легко.

Выбираем пустой элемент. Переходим на вкладку «Вставка». Выбираем раздел «Иллюстрации». Кликаем на пункт «Рисунки».

  1. Указываем файл и кликаем на кнопку «Вставить».
  1. Результат вас не разочарует. Смотрится очень красиво (в зависимости от подобранного рисунка).

Экспорт в Word

Для того чтобы скопировать данные в «вордовский» документ, достаточно сделать пару простых действий.

  1. Нажмите на горячие клавиши Ctrl+C.
  2. Откройте документ
  3. Теперь используем кнопки Ctrl+V.
  4. Итог будет следующим.

Онлайн-сервисы

Для тех, кто хочет работать в «реальном режиме» и делиться информацией с друзьями или коллегами по работе, существует отличный инструмент «Google Таблицы».

Используя этот сервис, вы сможете получить доступ к своим документам с любого устройства: компьютер, ноутбук, телефон или планшет.

Способы печати

Распечатка документов Word, как правило, задача несложная. Но с таблицами в Excel всё иначе. Самая большая проблема заключается в том, что «на глаз» сложно определить границы печати. И очень часто в принтере появляются практически пустые листы, на которых находится всего 1-2 строки таблицы.

Такие распечатки неудобны для восприятия. Намного лучше, когда вся информация находится на одном листе и никуда за границы не выходит. В связи с этим разработчики из Microsoft добавили функцию просмотра документов. Давайте рассмотрим, как этим пользоваться.

  1. Открываем документ. Он выглядит вполне обычно.
  1. Далее нажмите на горячие клавиши Ctrl+P. В появившемся окне мы видим, что информация не помещается на один лист. У нас исчезла графа «Общая стоимость». Кроме того, внизу нам подсказывают, что при печати будет использовано 2 страницы.

В версии 2007 года, для этого нужно было нажать на кнопку «Просмотр».

  1. Для отмены нажимаем горячую клавишу Esc. В результате появится вертикальная пунктирная линия, которая показывает границы печати.

Увеличить пространство при печати можно следующим образом.

  1. Первым делом уменьшаем поля. Для этого переходим на вкладку «Разметка страницы». Кликаем на кнопку «Поля» и выбираем самый «Узкий» вариант.
  1. После этого уменьшаем ширину столбцов, пока пунктирная линия не окажется за пределами последней колонки. Как это сделать, было описано выше.

Уменьшать нужно в разумных пределах, чтобы не страдала читабельность текста.

  1. Снова нажимаем на Ctrl+P. Теперь мы видим, что информация помещается на один лист.

Отличие версий продукции Майкрософт

Стоит понимать, что Эксель 2003 года уже давно морально устарел. Там отсутствует огромное количество современных функций и возможностей. Кроме этого, внешний вид различных объектов (графики, диаграммы и так далее) сильно уступает современным требованиям.

Пример рабочей области Excel 2003.

В современных 2007, 2010, 2013, а тем более 2016 версиях всё намного «круче».

Многие пункты меню находятся в разных разделах. Некоторые из них вовсе изменили своё название. Например, привычные нам «Формулы», в далёком 2003 назывались «Функциями». И они занимали не так уж много места.

Сейчас же для них отведена целая вкладка.

Ограничения и возможности разных версий

На официальном сайте компании Microsoft можно найти онлайн справку, в которой приводятся все технические характеристики создаваемых книг.

Пример самых основных параметров.

Этот список довольно длинный. Поэтому стоит перейти по ссылке и ознакомиться с остальными.

Обратите внимание, что версию 2003 года даже не рассматривают, так как её поддержка прекращена.

Но в некоторых бюджетных организациях этот офисный пакет используется и по сей день.

Заключение

В данной статье были рассмотрены различные способы создания и представления таблиц. Особое внимание было уделено приданию красивого внешнего вида. Не стоит переусердствовать в этом плане, поскольку яркие цвета и многообразие шрифтов будут отпугивать пользователя, который пытается ознакомиться с содержимым таблицы.

инструкция

Тем, у кого остались какие-нибудь вопросы, ниже прилагается видеоролик, в котором прилагаются дополнительные комментарии к описанным выше инструкциям.

Источник: https://os-helper.ru/excel/sozdaem-tablicu.html

Умные Таблицы Excel – секреты эффективной работы

Работаем в Экселе - построение и заполнение таблиц

:  5 / 5

В MS Excel есть много потрясающих инструментов, о которых большинство пользователей не подозревают или сильно недооценивают. К таковым относятся Таблицы Excel. Вы скажете, что весь Excel – это электронная таблица? Нет. Рабочая область листа – это только множество ячеек. Некоторые из них заполнены, некоторые пустые, но по своей сути и функциональности все они одинаковы.

Таблица Excel – совсем другое. Это не просто диапазон данных, а цельный объект, у которого есть свое название, внутренняя структура, свойства и множество преимуществ по сравнению с обычным диапазоном ячеек. Также встречается под названием “умные таблицы”.

Создание Таблицы Excel

В наличии имеется обычный диапазон данных о продажах.

Чтобы преобразовать этот диапазон в Таблицу, следует выделить любую ячейку и перейти Вставка → Таблицы → Таблица

либо нажать горячую клавишу Ctrl+T.

Появится маленькое диалоговое окно, где можно поправить диапазон и указать, что в первой строке находятся заголовки столбцов.

Как правило, ничего не меняем. После нажатия Ок исходный диапазон превратится в Таблицу Excel.

Перед тем как перейти к свойствам Таблицы, посмотрим вначале, как ее видит сам Excel. Многое сразу прояснится.

Структура и ссылки на Таблицу Excel

Каждая Таблица имеет свое название. Это видно во вкладке Конструктор, которая появляется при выделении любой ячейки Таблицы. По умолчанию оно будет «Таблица1», «Таблица2» и т.д. 

Если в вашей книге Excel планируется несколько Таблиц, то имеет смысл придать им более говорящие названия. В дальнейшем это облегчит их использование (например, при работе в Power Pivot или Power Query). Я изменю название на «Отчет». Таблица «Отчет» видна в диспетчере имен Формулы → Определенные Имена → Диспетчер имен.

А также при наборе формулы вручную.

Но самое интересное заключается в том, что Эксель видит не только целую Таблицу, но и ее отдельные части: столбцы, заголовки, итоги и др. Ссылки при этом выглядят следующим образом.

=Отчет[#Все] – на всю Таблицу
=Отчет[#Данные] – только на данные (без строки заголовка)
=Отчет[#Заголовки] – только на первую строку заголовков
=Отчет[#Итоги] – на итоги
=Отчет[@] – на всю текущую строку (где вводится формула)
=Отчет[Продажи] – на весь столбец «Продажи»
=Отчет[@Продажи] – на ячейку из текущей строки столбца «Продажи»

Для написания ссылок совсем не обязательно запоминать все эти конструкции. При наборе формулы вручную все они видны в подсказках после выбора Таблицы и открытии квадратной скобки (в английской раскладке).

Выбираем нужное клавишей Tab. Не забываем закрыть все скобки, в том числе квадратную.

Если в какой-то ячейке написать формулу для суммирования по всему столбцу «Продажи»

=СУММ(D2:D8)

то она автоматически переделается в

=Отчет[Продажи]

Т.е. ссылка ведет не на конкретный диапазон, а на весь указанный столбец.

А теперь о том, как Таблицы облегчают жизнь и работу.

Свойства Таблиц Excel

1. Каждая Таблица имеет заголовки, которые обычно берутся из первой строки исходного диапазона.

2. Если Таблица большая, то при прокрутке вниз названия столбцов Таблицы заменяют названия столбцов листа.

Очень удобно, не нужно специально закреплять области.

3. В таблицу по умолчанию добавляется автофильтр, который можно отключить в настройках. Об этом чуть ниже.

4. Новые значения, записанные в первой пустой строке снизу, автоматически включаются в Таблицу Excel, поэтому они сразу попадают в формулу (или диаграмму), которая ссылается на некоторый столбец Таблицы.

Новые ячейки также форматируются под стиль таблицы, и заполняются формулами, если они есть в каком-то столбце. Короче, для продления Таблицы достаточно внести только значения. Форматы, формулы, ссылки – все добавится само.

5. Новые столбцы также автоматически включатся в Таблицу.

6. При внесении формулы в одну ячейку, она сразу копируется во все остальные. Не нужно вручную протягивать.

Помимо указанных свойств есть возможность сделать дополнительные настройки.

Настройки Таблицы

В контекстной вкладке Конструктор находятся дополнительные инструменты анализа и настроек.

С помощью галочек в группе Параметры стилей таблиц

можно внести следующие изменения.

– Удалить или добавить строку заголовков

– Добавить или удалить строку с итогами

– Сделать формат строк чередующимися

– Выделить жирным первый столбец

– Выделить жирным последний столбец

– Сделать чередующуюся заливку строк

– Убрать автофильтр, установленный по умолчанию

В видеоуроке ниже показано, как это работает в действии.

В группе Стили таблиц можно выбрать другой формат. По умолчанию он такой как на картинках выше, но это легко изменить, если надо.

В группе Инструменты можно создать сводную таблицу, удалить дубликаты, а также преобразовать в обычный диапазон.

Однако самое интересное – это создание срезов.

Срез – это фильтр, вынесенный в отдельный графический элемент. Нажимаем на кнопку Вставить срез, выбираем столбец (столбцы), по которому будем фильтровать,

и срез готов. В нем показаны все уникальные значения выбранного столбца.

Для фильтрации Таблицы следует выбрать интересующую категорию.

Если нужно выбрать несколько категорий, то удерживаем Ctrl или предварительно нажимаем кнопку в верхнем правом углу, слева от снятия фильтра.

Попробуйте сами, как здорово фильтровать срезами (кликается мышью). 

Для настройки самого среза на ленте также появляется контекстная вкладка Параметры. В ней можно изменить стиль, размеры кнопок, количество колонок и т.д. Там все понятно.

Ограничения Таблиц Excel

Несмотря на неоспоримые преимущества и колоссальные возможности, у Таблицы Excel есть недостатки.

1. Не работают представления. Это команда, которая запоминает некоторые настройки листа (фильтр, свернутые строки/столбцы и некоторые другие).

2. Текущую книгу нельзя выложить для совместного использования.

3. Невозможно вставить промежуточные итоги.

4. Не работают формулы массивов.

5. Нельзя объединять ячейки. Правда, и в обычном диапазоне этого делать не следует.

Однако на фоне свойств и возможностей Таблиц, эти недостатки практически не заметны.

Ниже можно посмотреть видеоурок о Таблицах Excel.

Множество других секретов Excel вы найдете в онлайн курсе.

Источник: https://statanaliz.info/excel/rabota-s-dannymi/157-umnye-tablitsy-excel-secrety

Как работать в Excel с таблицами для чайников: пошаговая инструкция

Работаем в Экселе - построение и заполнение таблиц

Программа Microsoft Excel удобна для составления таблиц и произведения расчетов. Рабочая область – это множество ячеек, которые можно заполнять данными. Впоследствии – форматировать, использовать для построения графиков, диаграмм, сводных отчетов.

Работа в Экселе с таблицами для начинающих пользователей может на первый взгляд показаться сложной. Она существенно отличается от принципов построения таблиц в Word. Но начнем мы с малого: с создания и форматирования таблицы. И в конце статьи вы уже будете понимать, что лучшего инструмента для создания таблиц, чем Excel не придумаешь.

Работа с таблицами в Excel для чайников не терпит спешки. Создать таблицу можно разными способами и для конкретных целей каждый способ обладает своими преимуществами. Поэтому сначала визуально оценим ситуацию.

Посмотрите внимательно на рабочий лист табличного процессора:

Это множество ячеек в столбцах и строках. По сути – таблица. Столбцы обозначены латинскими буквами. Строки – цифрами. Если вывести этот лист на печать, получим чистую страницу. Без всяких границ.

Сначала давайте научимся работать с ячейками, строками и столбцами.

Чтобы выделить весь столбец, щелкаем по его названию (латинской букве) левой кнопкой мыши.

Для выделения строки – по названию строки (по цифре).

Чтобы выделить несколько столбцов или строк, щелкаем левой кнопкой мыши по названию, держим и протаскиваем.

Для выделения столбца с помощью горячих клавиш ставим курсор в любую ячейку нужного столбца – нажимаем Ctrl + пробел. Для выделения строки – Shift + пробел.

Как изменить границы ячеек

Если информация при заполнении таблицы не помещается нужно изменить границы ячеек:

  1. Передвинуть вручную, зацепив границу ячейки левой кнопкой мыши.
  2. Когда длинное слово записано в ячейку, щелкнуть 2 раза по границе столбца / строки. Программа автоматически расширит границы.
  3. Если нужно сохранить ширину столбца, но увеличить высоту строки, воспользуемся кнопкой «Перенос текста» на панели инструментов.

Для изменения ширины столбцов и высоты строк сразу в определенном диапазоне выделяем область, увеличиваем 1 столбец /строку (передвигаем вручную) – автоматически изменится размер всех выделенных столбцов и строк.

Примечание. Чтобы вернуть прежний размер, можно нажать кнопку «Отмена» или комбинацию горячих клавиш CTRL+Z. Но она срабатывает тогда, когда делаешь сразу. Позже – не поможет.

Чтобы вернуть строки в исходные границы, открываем меню инструмента: «»-«Формат» и выбираем «Автоподбор высоты строки»

Для столбцов такой метод не актуален. Нажимаем «Формат» – «Ширина по умолчанию». Запоминаем эту цифру. Выделяем любую ячейку в столбце, границы которого необходимо «вернуть». Снова «Формат» – «Ширина столбца» – вводим заданный программой показатель (как правило это 8,43 – количество символов шрифта Calibri с размером в 11 пунктов). ОК.

Как вставить столбец или строку

Выделяем столбец /строку правее /ниже того места, где нужно вставить новый диапазон. То есть столбец появится слева от выделенной ячейки. А строка – выше.

Нажимаем правой кнопкой мыши – выбираем в выпадающем меню «Вставить» (или жмем комбинацию горячих клавиш CTRL+SHIFT+”=”).

Отмечаем «столбец» и жмем ОК.

Совет. Для быстрой вставки столбца нужно выделить столбец в желаемом месте и нажать CTRL+SHIFT+”=”.

Все эти навыки пригодятся при составлении таблицы в программе Excel. Нам придется расширять границы, добавлять строки /столбцы в процессе работы.

Пошаговое создание таблицы с формулами

  1. Заполняем вручную шапку – названия столбцов. Вносим данные – заполняем строки. Сразу применяем на практике полученные знания – расширяем границы столбцов, «подбираем» высоту для строк.
  2. Чтобы заполнить графу «Стоимость», ставим курсор в первую ячейку. Пишем «=».

    Таким образом, мы сигнализируем программе Excel: здесь будет формула. Выделяем ячейку В2 (с первой ценой). Вводим знак умножения (*). Выделяем ячейку С2 (с количеством). Жмем ВВОД.

  3. Когда мы подведем курсор к ячейке с формулой, в правом нижнем углу сформируется крестик.

    Он указываем на маркер автозаполнения. Цепляем его левой кнопкой мыши и ведем до конца столбца. Формула скопируется во все ячейки.

  4. Обозначим границы нашей таблицы. Выделяем диапазон с данными. Нажимаем кнопку: «»-«Границы» (на главной странице в меню «Шрифт»). И выбираем «Все границы».

Теперь при печати границы столбцов и строк будут видны.

С помощью меню «Шрифт» можно форматировать данные таблицы Excel, как в программе Word.

Поменяйте, к примеру, размер шрифта, сделайте шапку «жирным». Можно установить текст по центру, назначить переносы и т.д.

Как создать таблицу в Excel: пошаговая инструкция

Простейший способ создания таблиц уже известен. Но в Excel есть более удобный вариант (в плане последующего форматирования, работы с данными).

Сделаем «умную» (динамическую) таблицу:

  1. Переходим на вкладку «Вставка» – инструмент «Таблица» (или нажмите комбинацию горячих клавиш CTRL+T).
  2. В открывшемся диалоговом окне указываем диапазон для данных. Отмечаем, что таблица с подзаголовками. Жмем ОК. Ничего страшного, если сразу не угадаете диапазон. «Умная таблица» подвижная, динамическая.

Примечание. Можно пойти по другому пути – сначала выделить диапазон ячеек, а потом нажать кнопку «Таблица».

Теперь вносите необходимые данные в готовый каркас. Если потребуется дополнительный столбец, ставим курсор в предназначенную для названия ячейку. Вписываем наименование и нажимаем ВВОД. Диапазон автоматически расширится.

Если необходимо увеличить количество строк, зацепляем в нижнем правом углу за маркер автозаполнения и протягиваем вниз.

Как работать с таблицей в Excel

С выходом новых версий программы работа в Эксель с таблицами стала интересней и динамичней. Когда на листе сформирована умная таблица, становится доступным инструмент «Работа с таблицами» – «Конструктор».

Здесь мы можем дать имя таблице, изменить размер.

Доступны различные стили, возможность преобразовать таблицу в обычный диапазон или сводный отчет.

Возможности динамических электронных таблиц MS Excel огромны. Начнем с элементарных навыков ввода данных и автозаполнения:

  1. Выделяем ячейку, щелкнув по ней левой кнопкой мыши. Вводим текстовое /числовое значение. Жмем ВВОД. Если необходимо изменить значение, снова ставим курсор в эту же ячейку и вводим новые данные.
  2. При введении повторяющихся значений Excel будет распознавать их. Достаточно набрать на клавиатуре несколько символов и нажать Enter.
  3. Чтобы применить в умной таблице формулу для всего столбца, достаточно ввести ее в одну первую ячейку этого столбца. Программа скопирует в остальные ячейки автоматически.
  4. Для подсчета итогов выделяем столбец со значениями плюс пустая ячейка для будущего итога и нажимаем кнопку «Сумма» (группа инструментов «Редактирование» на закладке «» или нажмите комбинацию горячих клавиш ALT+”=”).

Если нажать на стрелочку справа каждого подзаголовка шапки, то мы получим доступ к дополнительным инструментам для работы с данными таблицы.

Иногда пользователю приходится работать с огромными таблицами. Чтобы посмотреть итоги, нужно пролистать не одну тысячу строк. Удалить строки – не вариант (данные впоследствии понадобятся). Но можно скрыть. Для этой цели воспользуйтесь числовыми фильтрами (картинка выше). Убираете галочки напротив тех значений, которые должны быть спрятаны.

Источник: https://exceltable.com/sozdat-tablicu/kak-rabotat-v-excel-s-tablicami

Как сделать таблицу в Excel. Пошаговая инструкция

Работаем в Экселе - построение и заполнение таблиц

Таблицы в Excel представляют собой ряд строк и столбцов со связанными данными, которыми вы управляете независимо друг от друга.

Работая в Excel с таблицами, вы сможете создавать отчеты, делать расчеты, строить графики и диаграммы, сортировать и фильтровать информацию.

Если ваша работа связана с обработкой данных, то навыки работы с таблицами в Эксель помогут вам сильно сэкономить время и повысить эффективность.

Как работать в Excel с таблицами. Пошаговая инструкция

  • Данные должны быть организованы в строках и столбцах, причем каждая строка должна содержать информацию об одной записи, например о заказе;
  • Первая строка таблицы должна содержать короткие, уникальные заголовки;
  • Каждый столбец должен содержать один тип данных, таких как числа, валюта или текст;
  • Каждая строка должна содержать данные для одной записи, например, заказа. Если применимо, укажите уникальный идентификатор для каждой строки, например номер заказа;
  • В таблице не должно быть пустых строк и абсолютно пустых столбцов.

1. Выделите область ячеек для создания таблицы

Выделите область ячеек, на месте которых вы хотите создать таблицу. Ячейки могут быть как пустыми, так и с информацией.

2. Нажмите кнопку “Таблица” на панели быстрого доступа

На вкладке “Вставка” нажмите кнопку “Таблица”.

3. Выберите диапазон ячеек

В всплывающем вы можете скорректировать расположение данных, а также настроить отображение заголовков. Когда все готово, нажмите “ОК”.

4. Таблица готова. Заполняйте данными!

Поздравляю, ваша таблица готова к заполнению! Об основных возможностях в работе с умными таблицами вы узнаете ниже.

Форматирование таблицы в Excel

Для настройки формата таблицы в Экселе доступны предварительно настроенные стили. Все они находятся на вкладке “Конструктор” в разделе “Стили таблиц”:

Если 7-ми стилей вам мало для выбора, тогда, нажав на кнопку, в правом нижнем углу стилей таблиц, раскроются все доступные стили. В дополнении к предустановленным системой стилям, вы можете настроить свой формат.

Помимо цветовой гаммы, в меню “Конструктора” таблиц можно настроить:

  • Отображение строки заголовков – включает и отключает заголовки в таблице;
  • Строку итогов – включает и отключает строку с суммой значений в колонках;
  • Чередующиеся строки – подсвечивает цветом чередующиеся строки;
  • Первый столбец – выделяет “жирным” текст в первом столбце с данными;
  • Последний столбец – выделяет “жирным” текст в последнем столбце;
  • Чередующиеся столбцы – подсвечивает цветом чередующиеся столбцы;
  • Кнопка фильтра – добавляет и убирает кнопки фильтра в заголовках столбцов.

Как добавить строку или столбец в таблице Excel

Даже внутри уже созданной таблицы вы можете добавлять строки или столбцы. Для этого кликните на любой ячейке правой клавишей мыши для вызова всплывающего окна:

  • Выберите пункт “Вставить” и кликните левой клавишей мыши по “Столбцы таблицы слева” если хотите добавить столбец, или “Строки таблицы выше”, если хотите вставить строку.
  • Если вы хотите удалить строку или столбец в таблице, то спуститесь по списку в сплывающем окне до пункта “Удалить” и выберите “Столбцы таблицы”, если хотите удалить столбец или “Строки таблицы”, если хотите удалить строку.

Как отсортировать таблицу в Excel

Для сортировки информации при работе с таблицей, нажмите справа от заголовка колонки “стрелочку”, после чего появится всплывающее окно:

В окне выберите по какому принципу отсортировать данные: “по возрастанию”, “по убыванию”, “по цвету”, “числовым фильтрам”.

Как отфильтровать данные в таблице Excel

Для фильтрации информации в таблице нажмите справа от заголовка колонки “стрелочку”, после чего появится всплывающее окно:

  • “Текстовый фильтр” отображается когда среди данных колонки есть текстовые значения;
  • “Фильтр по цвету” также как и текстовый, доступен когда в таблице есть ячейки, окрашенные в отличающийся от стандартного оформления цвета;
  • “Числовой фильтр” позволяет отобрать данные по параметрам: “Равно…”, “Не равно…”, “Больше…”, “Больше или равно…”, “Меньше…”, “Меньше или равно…”, “Между…”, “Первые 10…”, “Выше среднего”, “Ниже среднего”, а также настроить собственный фильтр.
  • В всплывающем окне, под “Поиском” отображаются все данные, по которым можно произвести фильтрацию, а также одним нажатием выделить все значения или выбрать только пустые ячейки.

Если вы хотите отменить все созданные настройки фильтрации, снова откройте всплывающее окно над нужной колонкой и нажмите “Удалить фильтр из столбца”. После этого таблица вернется в исходный вид.

Как посчитать сумму в таблице Excel

Для того чтобы посчитать сумму колонки в конце таблицы, нажмите правой клавишей мыши на любой ячейке и вызовите всплывающее окно:

В списке окна выберите пункт “Таблица” => “Строка итогов”:

Внизу таблица появится промежуточный итог. Нажмите левой клавишей мыши на ячейке с суммой.

В выпадающем меню выберите принцип промежуточного итога: это может быть сумма значений колонки, “среднее”, “количество”, “количество чисел”, “максимум”, “минимум” и т.д.

Как в Excel закрепить шапку таблицы

Таблицы, с которыми приходится работать, зачастую крупные и содержат в себе десятки строк. Прокручивая таблицу “вниз” сложно ориентироваться в данных, если не видно заголовков столбцов. В Эксель есть возможность закрепить шапку в таблице таким образом, что при прокрутке данных вам будут видны заголовки колонок.

Для того чтобы закрепить заголовки сделайте следующее:

  • Перейдите на вкладку “Вид” в панели инструментов и выберите пункт “Закрепить области”:
  • Выберите пункт “Закрепить верхнюю строку”:
  • Теперь, прокручивая таблицу, вы не потеряете заголовки и сможете легко сориентироваться где какие данные находятся:

Как перевернуть таблицу в Excel

Представим, что у нас есть готовая таблица с данными продаж по менеджерам:

На таблице сверху в строках указаны фамилии продавцов, в колонках месяцы. Для того чтобы перевернуть таблицу и разместить месяцы в строках, а фамилии продавцов нужно:

  • Выделить таблицу целиком (зажав левую клавишу мыши выделить все ячейки таблицы) и скопировать данные (CTRL+C):
  • Переместить курсор мыши на свободную ячейку и нажать правую клавишу мыши. В открывшемся меню выбрать “Специальная вставка” и нажать на этом пункте левой клавишей мыши:
  • В открывшемся окне в разделе “Вставить” выбрать “значения” и поставить галочку в пункте “транспонировать”:
  • Готово! Месяцы теперь размещены по строкам, а фамилии продавцов по колонкам. Все что остается сделать – это преобразовать полученные данные в таблицу.

В этой статье вы ознакомились с принципами работы в Excel с таблицами, а также основными подходами в их создании. Пишите свои вопросы в комментарии!

Источник: https://excelhack.ru/kak-sdelat-tablicu-v-excel/

Сводные таблицы в Excel

Работаем в Экселе - построение и заполнение таблиц

Жизнь человека из мира технологий — это невероятная комбинация цифр, показателей, которые периодически требуют систематизации. Чтобы осуществить последнее, приходится использовать особые технические инструменты. Наша статья докажет, что сводные таблицы в Excel доступны даже для чайников.

Немного теории

Сводные таблицы Excel (для чайника) — это разновидность реестра, которая содержит конкретную часть данных из источника для анализа и изображена так, чтобы можно было проследить между ними логические связи. Основа для ее проектирования – определенный список значений.

Прежде чем начать работу, стоит подготовить для неё необходимые материалы, которые можно свести для анализа. Формируя подготовительный вариант, следите за тем, чтобы данные были классифицированы, например, цифры не путались с буквенным обозначением, а все столбцы имели заголовки.

Сводные таблицы в Excel незаменимы для тех, кто по роду занятости имеет дело с большим количеством цифр, которые периодически необходимо систематизировать и формировать отчетность.

Программа Excel поможет подсчитать и проанализировать большое количество значений, сэкономив время.

Плюсы использования такого вида группировки данных:

  • во время работы не нужны особые познания из сферы программирования, метод подойдет и для чайников;
  • возможность комбинировать информацию из других первоисточников;
  • можно пополнять базовый экземпляр новой информацией, несколько подкорректировав параметры.

Обучение работе со сводными таблицами в Excel не займет много времени и может основываться на видео.

Пример создания сводной таблицы Excel – алгоритм для чайников

Ознакомившись с базовыми теоретическими нюансами про сводные таблицы в Excel, давайте перейдем к применению их на деле. Для старта создания сводной таблицы в Excel 2016, 2010 или 2007 необходимо установить программное обеспечение.

Как правило, если вы пользуетесь программами системы Microsoft Office, то Excel уже есть на вашем компьютере.

Запустив его, перед вами откроется обширное поле, разделенное на большое количество ячеек.

Более детально о том, как делать сводные таблицы в Excel, вам подскажет видеоурок выше.

С помощью следующего алгоритма мы детально рассмотрим пример, как построить сводную таблицу в Excel. На панели вверху окна переходим на вкладку «Вставка», где слева в углу выбираем «Сводная таблица».

Далее на экране открывается диалоговое окошко, где требуется указать соответствующие параметры. На этом этапе создания сводных таблиц в Excel есть несколько важных моментов. Если перед тем, как начать формирование реестра, вы установили значок курсора на листе, то заполнение пустых строчек окна произойдёт автоматически. Иначе адрес диапазона данных нужно обозначить самостоятельно.
Рассмотрим детальней самостоятельное заполнение пунктов диалогового окна.

Первую строку не оставляем пустой, иначе программа выдаст ошибку. Если есть источник, с которого планируете переноситься данные, то выберите его в пункте «Использовать внешний источник данных». Под внешним источником подразумевается другая книга Excel или набор моделей данных из СУБД.

Заранее озаглавьте каждый столбик

Выберите место, где будет располагаться будущая рамка с ячейками. Это может быть новое окно или же этот лист, рекомендуем использовать другой лист.
Закрепив все настройки, получаем готовую основу. По левую сторону располагается область, где размещена основа будущей рамки. В правой части есть окно с настройками, которое помогает управлять реестром.

Теперь необходимо разобраться, как строится вся эта конструкция. В окне настроек «Поля свободной таблицы», вы обозначаете данные, которые будут присутствовать. Вся структура строится таким образом, чтобы текстовые данные играли роль объединяющих элементов, а числовые показывали консолидированные значения. Например, объединим все поступления по отделам и узнаем на какую сумму получил товары каждый. Для этого поставим галочку у двух заголовков: отдел и стоимость товара в партии. Обратите внимание, как расположились эти данные в нижней области панели настройки. Отдел автоматически ушел в строки, а числовые данные в значения. Если попробовать щелкнуть по любому столбцу с числами, они будут появляться в этой области. А в самой таблице добавится новый столбец.
При этом происходит суммирование. Сейчас мы можем узнать из нашего отчета, сколько товаров поступило в каждый отдел и их общую стоимость.

Вы можете свободно корректировать ширину столбиков для оптимального расположения данных. Просто раздвигайте ширину столбцов или высоту строк так, как вы привыкли в Excel.
Если вам не нравится такая ориентация, вы можете перетащить мышкой названия строк в область столбцов – просто наведите мышь, нажмите левую кнопку и тяните.

Что касается подсчета результатов, то сумма – далеко не единственная функция. Чтобы посмотреть, какие Excel предлагает еще, нажмите на название в области значений и выберите последнюю команду. В параметрах полей значений вы найдете множество вариантов для анализа. Для каждого значения можно выбрать свою функцию. Например, добавим поле «Цена» и найдем максимальную цену товара в каждом отделе. Фактически, узнаем сколько стоит самый дорогой. Теперь мы видим, что в отдел «Аксессуары» поступило товаров на сумму 267660 рублей, при этом самый дорогостоящий имеет цену 2700 рублей. Область «Фильтры» позволяет установить критерий отбора записей. Добавим поле «Дата поступление», просто поставив около него галочку. Сейчас сводная таблица в Excel выглядит неудобно, если нам необходимо провести анализ по дате. Поэтому переместим дату из строк в фильтры – просто перетяните, как было указано выше. Итогом этих действий стало появление еще одного поля сверху. Чтобы выбрать дату, нажмем на стрелочку около слова «Все». Теперь нам доступен выбор конкретного дня, чтобы открыть список, щелкайте по треугольнику в правом углу. Также можно выбрать и значения для отдела.
Снимите галочки с тех, которые вас не интересуют, и вы получите только нужную информацию. Вам может быть интересно:  Сумма прописью в Excel

Во время работы вы можете столкнуться с подобным сообщением «недопустимое имя сводной таблицы Excel». Это означает, что первая строка диапазона, откуда пытаются извлечь информацию, осталась с незаполненными ячейками. Чтобы решить эту проблему, вы должны заполнить пустоты колонки.

Обновление данных в сводной таблице в Excel

Важным вопросом является то, как сделать и обновить сводную таблицу в Excel 2010 или другой версии. Это актуально тогда, когда вы собираетесь добавить новые данные.

Если обновление будет проходить только для одного столбца, то необходимо на любом её месте щелкнуть правой кнопкой мыши. В появившемся окне нужно нажать «Обновить».

Если же подобное действие необходимо провести сразу с несколькими столбцами и строками, то выделите любую зону и на верхней панели откройте вкладку «Анализ» и кликните на значок «Обновить». Дальше выбирайте желаемое действие.

Если сводная таблица в Excel не нужна, то стоит разобраться, как её удалить. Это не составит большого труда. Выделите все составляющие вручную, или используя сочетание клавиш «CTRL+A». Далее нажмите клавишу «DELETE» и поле будет очищено.

Как в сводную таблицу Excel добавить столбец или таблицу

Чтобы добавить дополнительный столбец, вам необходимо добавить его в исходные данные и расширить диапазон для нашего реестра.
Перейдите на вкладку «Анализ» и откройте источник данных.

Excel сам все предложит. Обновите и вы получите новый перечень полей в области настройки.
Добавить таблицу вы сможете только если «склеите» ее с исходной. Можно заменить диапазон в уже существующей, но добавить «на лету» другой диапазон нельзя. Зато можно создать новую сводную таблицу на основе нескольких исходных, даже расположенных на разных листах.

Как сделать сводную таблицу в Excel из нескольких листов

Для этого нам понадобится мастер сводных таблиц. Добавим его на панель быстрого доступа (самый верх окна – слева). Нажмите выпадающую стрелочку и выберите «Другие команды».
Выберите все команды.

И найдите мастер сводных таблиц Excel, кликните по нему, затем на «Добавить» и ОК. Значок появится сверху. У вас должны быть две идентичные по полям таблицы на разных листах. У нас это данные о поступлениях в отделы за май и июнь. Нажимайте на ярлык мастера сводных таблиц и выбирайте консолидацию диапазонов. Нам нужно несколько полей, а не одно. На следующем этапе выделите первый диапазон и нажмите кнопку «Добавить». Затем переключитесь на другой лист ( щелкните по его названию внизу) и снова «Добавить». У вас будут созданы два диапазона. Не стоит выделять всю таблицу целиком. Нам нужна информация о поступлениях в отделы, поэтому мы выделили диапазон, начиная со столбца «Отдел». Дайте имя каждому. Кликайте кружочек 1, затем в поле вписывайте «май», кликайте кружочек 2 и вписывайте в поле 2 «июнь». Не забывайте менять диапазоны в области. Должен быть выделен тот, который именуем. Щелкайте «Далее» и создавайте на новом листе. После нажатия на «Готово» получим результат. Это многомерная таблица, так что управлять ей довольно сложно. Поэтому мы и выбрали диапазон меньше, чтобы не запутаться в измерениях. Обратите внимание, что у нас уже нет четких названий полей. Их можно вытащить, нажав на пункты в верхней области. Снимая или устанавливая галочки, вы регулируете значения, которые вам необходимо увидеть. Неудобно и то, что расчет проводится для всех значений одинаковый.
Как видите, у нас одно значение в соответствующей области.

Изменение структуры отчёта

Мы поэтапно разобрали пример, как создать сводную таблицу Exce, а как получить данные другого вида расскажем далее. Для этого мы изменим макет отчета. Установив курсор на любой ячейке, переходим во вкладку «Конструктор», а следом «Макет отчета».

Вам откроются на выбор три типа для структуризации информации:

Такой тип программа применяется автоматически. Данные не растягиваются, поэтому прокручивать изображения практически не нужно. Можно сэкономить место на подписях и оставить его для чисел.

https://www.youtube.com/watch?v=meJR-8WMeSM

Все показатели подаются иерархично: от малого к большому.

Информация представляется под видом реестра. Это позволяет легко переносить ячейки на новые листы.

Остановив выбор на подходящем макете, вы закрепляете внесенные коррективы.

Итак, мы рассказали, как составить поля сводной таблицы MS Excel 2016 (в 2007, 2010 действуйте по аналогии). Надеемся, эта информация поможет вам осуществлять быстрый анализ консолидированных данных.

Источник: https://WindowsTips.ru/svodnye-tablicy-v-excel

HelpIcs
Добавить комментарий