Построение диаграммы в Excel 2007 – создание и редактирование

Содержание

Как построить диаграмму по таблице в Excel: пошаговая инструкция

Построение диаграммы в Excel 2007 - создание и редактирование

Любую информацию легче воспринимать, если она представлена наглядно. Это особенно актуально, когда мы имеем дело с числовыми данными. Их необходимо сопоставить, сравнить. Оптимальный вариант представления – диаграммы. Будем работать в программе Excel.

Так же мы научимся создавать динамические диаграммы и графики, которые автоматически обновляют свои показатели в зависимости от изменения данных. По ссылке в конце статьи можно скачать шаблон-образец в качестве примера.

  1. Создаем таблицу с данными.
  2. Выделяем область значений A1:B5, которые необходимо презентовать в виде диаграммы. На вкладке «Вставка» выбираем тип диаграммы.
  3. Нажимаем «Гистограмма» (для примера, может быть и другой тип). Выбираем из предложенных вариантов гистограмм.
  4. После выбора определенного вида гистограммы автоматически получаем результат.
  5. Такой вариант нас не совсем устраивает – внесем изменения. Дважды щелкаем по названию гистограммы – вводим «Итоговые суммы».
  6. Сделаем подпись для вертикальной оси. Вкладка «Макет» – «Подписи» – «Названия осей». Выбираем вертикальную ось и вид названия для нее.
  7. Вводим «Сумма».
  8. Конкретизируем суммы, подписав столбики показателей. На вкладке «Макет» выбираем «Подписи данных» и место их размещения.
  9. Уберем легенду (запись справа). Для нашего примера она не нужна, т.к. мало данных. Выделяем ее и жмем клавишу DELETE.
  10. Изменим цвет и стиль.

Выберем другой стиль диаграммы (вкладка «Конструктор» – «Стили диаграмм»).



  1. Добавляем в таблицу новые значения – План.
  2. Выделяем диапазон новых данных вместе с названием. Копируем его в буфер обмена (одновременное нажатие Ctrl+C). Выделяем существующую диаграмму и вставляем скопированный фрагмент (одновременное нажатие Ctrl+V).
  3. Так как не совсем понятно происхождение цифр в нашей гистограмме, оформим легенду. Вкладка «Макет» – «Легенда» – «Добавить легенду справа» (внизу, слева и т.д.). Получаем:

Есть более сложный путь добавления новых данных в существующую диаграмму – с помощью меню «Выбор источника данных» (открывается правой кнопкой мыши – «Выбрать данные»).

Когда нажмете «Добавить» (элементы легенды), откроется строка для выбора диапазона данных.

Как поменять местами оси в диаграмме Excel?

  1. Щелкаем по диаграмме правой кнопкой мыши – «Выбрать данные».
  2. В открывшемся меню нажимаем кнопку «Строка/столбец».
  3. Значения для рядов и категорий поменяются местами автоматически.

Как закрепить элементы управления на диаграмме Excel?

Если очень часто приходится добавлять в гистограмму новые данные, каждый раз менять диапазон неудобно. Оптимальный вариант – сделать динамическую диаграмму, которая будет обновляться автоматически. А чтобы закрепить элементы управления, область данных преобразуем в «умную таблицу».

  1. Выделяем диапазон значений A1:C5 и на «Главной» нажимаем «Форматировать как таблицу».
  2. В открывшемся меню выбираем любой стиль. Программа предлагает выбрать диапазон для таблицы – соглашаемся с его вариантом. Получаем следующий вид значений для диаграммы:
  3. Как только мы начнем вводить новую информацию в таблицу, будет меняться и диаграмма. Она стала динамической:

Мы рассмотрели, как создать «умную таблицу» на основе имеющихся данных. Если перед нами чистый лист, то значения сразу заносим в таблицу: «Вставка» – «Таблица».

Как сделать диаграмму в процентах в Excel?

Представлять информацию в процентах лучше всего с помощью круговых диаграмм.

Исходные данные для примера:

  1. Выделяем данные A1:B8. «Вставка» – «Круговая» – «Объемная круговая».
  2. Вкладка «Конструктор» – «Макеты диаграммы». Среди предлагаемых вариантов есть стили с процентами.
  3. Выбираем подходящий.
  4. Очень плохо просматриваются сектора с маленькими процентами. Чтобы их выделить, создадим вторичную диаграмму. Выделяем диаграмму. На вкладке «Конструктор» – «Изменить тип диаграммы». Выбираем круговую с вторичной.
  5. Автоматически созданный вариант не решает нашу задачу. Щелкаем правой кнопкой мыши по любому сектору. Должны появиться точки-границы. Меню «Формат ряда данных».
  6. Задаем следующие параметры ряда:
  7. Получаем нужный вариант:

Диаграмма Ганта в Excel

Диаграмма Ганта – это способ представления информации в виде столбиков для иллюстрации многоэтапного мероприятия. Красивый и несложный прием.

  1. У нас есть таблица (учебная) со сроками сдачи отчетов.
  2. Для диаграммы вставляем столбец, где будет указано количество дней. Заполняем его с помощью формул Excel.
  3. Выделяем диапазон, где будет находиться диаграмма Ганта. То есть ячейки будут залиты определенным цветом между датами начала и конца установленных сроков.
  4. Открываем меню «Условное форматирование» (на «Главной»). Выбираем задачу «Создать правило» – «Использовать формулу для определения форматируемых ячеек».
  5. Вводим формулу вида: =И(E$2>=$B3;E$2

Когда вам нужно построит презентабельный отчет финансовой активности предприятия, лучше использовать средства графического представления информации.

Графическое представление информации намного эффективней и быстрей усваивается человеческим зрительным восприятием информации, чем текст и цифры. Легче проводить аналитики, лучше видно ситуацию, как в целом, так и в отдельных деталях.

Простенькая диаграмма Ганта готова. Скачать шаблон с примером в качестве образца.

В программе Excel специально разрабатывались диаграммы и графики для реализации данной задачи.

Источник: https://exceltable.com/grafiki/kak-postroit-diagrammu-excel

6. Диаграммы в Excel

Построение диаграммы в Excel 2007 - создание и редактирование

Windows XP Word 2003 Excel 2003

на предыдущую  на следующую

6.1. Построение диаграмм
6.2. Редактирование диаграмм

В программе Excel термин диаграмма используется для обозначения всех видов графического представления числовых данных. Основными типамидиаграмм являются: график, гистограмма, круговаядиаграмма.

Построение графического изображения производится на основе ряда данных. Так называют диапазон ячеек с числовыми значениями в пределах отдельной строки или столбца. На одной диаграмме можно отображать несколько рядов данных.

К построенной диаграмме автоматически добавляется легенда – расшифровка рядов данных.

Диаграмма является объектом, вставленным на один из листов рабочей книги. Она может располагаться на том же листе, на котором находятся данные или на отдельном листе. Диаграмма сохраняет связь с данными, на основе которых она построена, и при обновлении этих данных немедленно изменяет свой вид.

Для построения диаграммы предназначен Мастер диаграмм.

Как правило, диапазон данных, которые будут отображаться на диаграмме, выделяют заранее, но указать данные можно и в ходе работы Мастера диаграмм.

Построение диаграмм

  1. Выделить ряды данных вместе с подписями столбцов (тогда они будут отображены в легенде). Для графиков и гистограмм можно выделять несколько рядов данных. В этом случае несколько графиков или столбцов гистограммы будут расположены в одной области построения. Для круговой диаграммы выделяется один ряд данных.

    Если нужны подписи по оси Х (или подписи секторов круговой диаграммы), то следует выделить и столбец с текстовыми данными. Если в качестве подписей должен использоваться ряд с числовыми значениями, то на этом этапе его не нужно выделять.

  2. Запустить Мастер диаграмм кнопкой в панели инструментов или командой меню ВставкаДиаграмма
  3. Далее работа выполняется с последовательными окнами Мастера диаграмм. Переход к очередному окну выполняется щелчком на кнопке Далее.

Первый шаг Мастера окно Тип диаграммы (рисунок 6.1). Здесь выбирается тип и вид диаграммы.

Рис. 6.1

На вкладке Стандартные перечислены различные типы диаграмм и варианты представления каждого типа. Ниже приводится краткое описание выбранного варианта. Удерживая мышью кнопку Просмотр результата, можно увидеть будущую диаграмму, если диапазон данных был заранее выделен.

На вкладке Нестандартныеотображается набор разных типов диаграмм с готовым форматированием. На этой вкладке можно выбрать построение смешанной диаграммы, например, гистограммы и графика по разным рядам данных в одной области построения.

Второй шаг Мастера – окно Источник данных диаграммы.

На вкладке Диапазон данных(рисунок 6.2) указан выделенный диапазон. Если данные не были выделены заранее или потребовалось включить другие ряды данных, следует щелкнуть в поле Диапазон и выделить данные в таблице.

Переключатель ряда данных (в строках или столбцах) устанавливается автоматически – по логике выбранных данных.

Вкладка Ряд (рисунок 6.3) используется для корректировки рядов данных, по которым строится диаграмма, и подписей по оси Х.

Рис. 6.2

Рис. 6.3

Поле Ряд содержит список всех выбранных рядов с числовыми данными. Если данные выделялись с подписями, то список рядов содержит эти названия и в поле имени отображается адрес ячейки, содержащей подпись. Если подписи рядов не были выделены, то рядам присваиваются стандартные имена (Ряд1, Ряд2…).

Ряд данных можно исключить из списка представления, щелкнув на кнопке Удалить. Для подключения ряда данных нужно щелкнуть на кнопке Добавить и выделить данные в таблице.

Если данные, предназначенные в качестве подписей по оси Х, не были выделены заранее, их можно выбрать, щелкнув в поле Подписи по оси Х (подписи категорий).

Третий шаг Мастера – окно Параметры диаграммы.

Это окно содержит несколько вкладок, количество и поля которых зависят от типа диаграммы (рисунок 6.4).

Рис. 6.4

Установка каждого параметра сразу отображается в области просмотра.

  1. На вкладке Заголовки можно ввести название диаграммы и подписи осей (для круговых диаграмм – только название).
  2. На вкладке Оси устанавливают отображение и маркировку осей координат.
  3. На вкладке Легенда можно указать отображение или отсутствие легенды и выбрать место ее размещения.
  4. На вкладке Линии сетки устанавливается отображение основных и промежуточных линий сетки в области построения диаграммы.
  5. На вкладке Подписи данных можно выбрать отображение подписей элементов данных на диаграмме:
    • имена рядов;
    • имена категорий;
    • значения.
  6. На вкладке Таблица данных можно добавить к диаграмме таблицу рядов данных, использованных в диаграмме.

Четвертый шаг Мастера – окно Размещение диаграммы.

На последнем шаге работы Мастера запрашивается, где следует поместить диаграмму – на отдельном листе или на одном из имеющихся. При выборе первого варианта в рабочей книге появится новый лист со стандартным именем – Диаграмма.

6.2.  Редактирование диаграмм

Готовую диаграмму можно перемещать по рабочему листу, изменять ее размер. Чтобы удалить диаграмму, нужно выделить ее и нажать клавишу . Если диаграмма расположена на отдельном листе – удалить лист.

Диаграмма состоит из элементов, каждый из которых можно редактировать отдельно.

Элементы диаграммы (см. рисунок 6.5):

  • область диаграммы – это вся диаграмма;
  • область построения – область размещения графиков, гистограмм (для круговых диаграмм этой области нет);
  • ряды данных – это сами графики, столбики гистограммы, сектора круговой диаграммы;
  • оси координат – ось Х (ось категорий) и ось Y (ось значений);
  • заголовок диаграммы;
  • легенда;
  • линии сетки (для круговых диаграмм – отсутствуют).

Наведение указателя мыши на любой элемент вызывает всплывающую подсказку. При щелчке на элементе, он выделяется маркерами, а его название отображается в левой части строки формул.

Рис. 6.5

Редактирование элементов диаграммы выполняется в диалоговых окнах Формат, которые можно вызвать разными способами:

  • двойным щелчком на элементе;
  • контекстное меню элементаФормат;
  • меню Формат для выделенного элемента.
  • Контекстное меню области диаграммы, кроме команды Формат, содержит команды:
  1. Тип диаграммы
  2. Исходные данные…
  3. Параметры диаграммы…
  4. Размещение

Эти команды открывают соответствующие окна Мастера диаграмм, что дает возможность исправить недочеты, допущенные при построении диаграммы.

Особенности выделения рядов данных:

  1. щелчок на линии графика выделяет весь график, повторный щелчок – выделит отдельный его участок, соответствующий одному значению ряда;
  2. щелчок на любом столбике гистограммы выделяет все столбики соответствующего ряда данных; повторный щелчок – выделит этот столбик;
  3. щелчок на круговой диаграмме выделяет всю диаграмму, повторный щелчок на любом секторе – выделит этот сектор.

Добавление рядов данных (способы):

  • выделить данные в таблице и перетащить мышью в область построения;
  • контекстное меню области диаграммыИсходные данныевкладка Рядкнопка Добавить.

Таким же образом можно добавить подписи по оси Х.

Шрифт заголовка, легенды, подписей

  • кнопки параметров шрифта в панели инструментов;
  • в диалоговом окне Формат (соответствующего элемента) вкладка Шрифт.

Цветобласти построения (по умолчанию серый цвет):

  • кнопка Цвет заливки в панели инструментов;
  • в диалоговом окне Формат области построения вкладка Вид.

Цвет и узор столбиков гистограммы или секторов круговой диаграммы:

  • кнопка Цвет заливкив панели инструментов;
  • в диалоговом окне Формат рядов данных вкладка Вид (кнопка Способы заливки).

Линия графика:

в диалоговом окне Формат ряда данных на вкладке Вид можно изменить цвет и толщину линии, сделать линию сглаженной (установить флажок), а также изменить или убрать маркеры на графике.

Линии сетки области построения графиков и гистограмм:

  • в диалоговом окне Параметры диаграммы на вкладке Линии сеткиустанавливается наличие или отсутствие линий сетки.
  • в диалоговом окне Формат линий сетки на вкладке Вид устанавливается тип, цвет и толщина линий сетки.

в начало на предыдущую   на следующую

Источник: http://yuschikev.narod.ru/Teoria/Excel2003/Excel6.html

Как сделать диаграмму в Excel по данным таблицы

Построение диаграммы в Excel 2007 - создание и редактирование

Эксель – одна из самых лучших программ для работы с таблицами. Она есть на компьютере практически у каждого пользователя, поскольку данный редактор нужен как для работы, так и для учёбы, во время выполнения различных курсовых или лабораторных заданий.

Но при этом не все знают, как сделать диаграмму в Excel по данным таблицы. В этом редакторе вы сможете использовать огромное количество шаблонов, которые были разработаны в компании Microsoft.

Но если вы не знаете, какой тип лучше выбрать, то предпочтительнее будет использовать автоматический режим.

Как вставить рекомендуемую диаграмму

Для того чтобы построить подобный объект, необходимо выполнить следующие действия.

  1. Создайте какую-нибудь таблицу.
  1. Выделите информацию, на основе которой вы собираетесь построить диаграмму.
  1. Перейдите на вкладку «Вставка». Кликните на иконку «Рекомендуемые диаграммы».
  1. После этого вы увидите окно «Вставка диаграммы». Предложенные варианты будут зависеть от того, что именно вы выделите (перед нажатием на кнопку). У вас они могут быть другие, поскольку всё зависит от информации в таблице.
  1. Для того чтобы построить диаграмму, выберите любую из них и нажмите на «OK».
  1. В данном случае объект будет выглядеть вот так.

Ручной выбор типа диаграммы

Если вам ничто из рекомендуемых вариантов не понравилось, вы всегда можете выбрать что-то на панели инструментов. Для этого необходимо сделать следующие шаги.

  1. Выделите нужные вам данные для анализа.
  1. Затем кликните на какую-нибудь иконку из указанной области.
  1. Сразу после этого раскроется список различных типов объектов.
  1. Кликнув на любой из них, вы получите желаемую диаграмму.

Для того чтобы было легче определиться с выбором, достаточно навести на любую из миниатюр.

Какие бывают диаграммы

Можно выделить несколько основных категорий:

  • график или диаграмма с областями;
  • круговые или кольцевые диаграммы;

Обратите внимание на то, что данный тип подходит для тех случаев, когда все значения в сумме дают 100 процентов.

  • статистическая диаграмма;
  • точечный или пузырьковый график;

В данном случае точка является своеобразным маркером.

  • каскадная или биржевая диаграмма;
  • комбинированная диаграмма;

Если ничего из выше предложенного вам не подходит, можно использовать комбинированные варианты.

  • поверхностная или лепестковая;

Как сделать сводную диаграмму

Данный инструмент более сложный по сравнению с описанными выше. Ранее всё происходило автоматически. Вам нужно было только выбрать внешний вид и желаемый тип. Здесь всё иначе. На этот раз придется всё делать вручную.

  1. Выделите нужные ячейки в таблице и кликните на соответствующую иконку.
  1. Сразу после этого появится окно «Создать сводную диаграмму». Необходимо указать:
    • таблицу или диапазон значений;
    • место, где следует разместить объект (на новый или текущий лист).
  2. Для продолжения нажмите на кнопку «OK».
  1. В результате этого вы увидите:
    • пустую сводную таблицу;
    • пустую диаграмму;
    • поля сводной диаграммы.
  1. Необходимо перенести мышкой желаемые поля в области (по своему усмотрению):
  1. Кроме этого, вы можете настроить, какое именно значение нужно выводить. Для этого сделайте правый клик мыши по каждому полю и нажмите на пункт «Параметры полей значений…».
  1. В результате этого появится окно «Параметры поля значений». Здесь вы сможете:
    • подписать источник своим имением;
    • выбрать операцию, которую следует использовать для сведения данных в выбранном поле.

Для сохранения нажмите на кнопку «OK».

Вкладка «Анализировать»

После того как вы создадите сводную диаграмму, у вас откроется новая вкладка «Анализировать». Она сразу же исчезнет, если активным станет другой объект. Для возврата достаточно снова кликнуть на диаграмму.

https://www.youtube.com/watch?v=1VDfnG4Q3e0

Рассмотрим каждый раздел более внимательно, поскольку при помощи их можно изменить все элементы до неузнаваемости.

Параметры сводной таблицы

  1. Нажмите на самую первую иконку.
  2. Выберите пункт «Параметры».
  1. Благодаря этому появится окно настроек данного объекта. Здесь вы сможете задать желаемое имя таблицы и множество других параметров.

Для сохранения настроек необходимо кликнуть на кнопку «OK».

Как изменить активное поле

Если вы кликните на эту иконку, то увидите, что все инструменты не активны.

Для того чтобы можно было изменить какой-нибудь элемент, нужно сделать следующее.

  1. Кликните на что-нибудь на вашей диаграмме.
  1. В результате этого данное поле выделится «кружочками».
  2. Если вы снова кликните на иконку «Активное поле», то увидите, что инструменты стали активными.
  1. Для настроек нужно кликнуть на соответствующее поле.
  1. В результате этого появится окно «Параметры поля».
  1. Для дополнительных настроек перейдите на вкладку «Разметка и печать».
  1. Чтобы сохранить внесенные изменения, необходимо нажать на кнопку «OK».

Как вставить срез

При желании вы можете настроить выборку по определенным значениям. Благодаря этой функции очень удобно анализировать данные. Особенно если таблица очень большая. Для того чтобы воспользоваться этим инструментом, нужно сделать следующие шаги:

  1. Кликните на кнопку «Вставить срез».
  2. В результате этого появится окно со списком полей, которые есть в сводной таблице.
  1. Выберите какое-нибудь поле и нажмите на кнопку «OK».
  1. В результате этого появится маленькое окошко (его можно перемещать в любое удобное место) со всеми уникальными значениями (итогов сведения) для этой таблицы.
  1. Если вы нажмете на какую-нибудь строчку, то увидите, что все остальные записи в таблице исчезли. Осталось только то, где среднее значение соответствует выбранному.

То есть по умолчанию (когда в окне срезов все строчки выделены голубым цветом) в таблице отображаются все значения.

  1. Если кликнуть на другую цифру, то результат сразу же изменится.
  1. Количество строк может быть абсолютно любым (минимум одна).

Меняться будет как сводная таблица, так и диаграмма, которая построена по ее значениям.

  1. Если хотите удалить срез, нужно кликнуть на крестик в правом верхнем углу.
  1. Благодаря этому таблица восстановится до исходного вида.

Для того чтобы убрать это окно срезов, необходимо сделать несколько несложных шагов:

  1. Кликните правой кнопкой мыши по данному элементу.
  2. После этого появится контекстное меню, в котором нужно выбрать пункт «Удалить ‘название поля’».
  1. Результат будет следующим. Обратите внимание на то, что в правой части редактора снова появилась панель для настройки полей сводной таблицы.

Как вставить временную шкалу

Для того чтобы вставить срез по дате, нужно сделать следующие шаги.

  1. Кликните на соответствующую кнопку.
  1. В нашем случае мы увидим следующее окно с ошибкой.

Дело в том, что для среза по дате в таблице должны быть соответствующие значения.

Принцип работы полностью идентичен. Просто вы будете фильтровать вывод записей не по цифрам, а по датам.

Как обновить данные в диаграмме

Для обновления информации в таблице нужно кликнуть на соответствующую кнопку.

Как изменить информацию для построения

Для редактирования диапазона ячеек в таблице необходимо выполнить следующие операции:

  1. Кликните на иконку «Источник данных».
  2. В появившемся меню выберите одноименный пункт.
  1. Далее вас попросят указать нужные ячейки.
  2. Для сохранения изменений кликните на «OK».

Редактирование диаграммы

Если вы работаете с диаграммой (неважно какой – обычной или сводной), у вас будет появляться вкладка «Конструктор».

На этой панели очень много инструментов. Рассмотрим каждый из них более внимательно.

Добавить элемент

При желании вы всегда можете добавить какой-нибудь объект, который отсутствует в данном шаблоне диаграммы. Для этого необходимо:

  1. Нажать на иконку «Добавить элемент диаграммы».
  2. Выбрать желаемый объект.

Благодаря этому меню вы сможете изменить свою диаграмму и таблицу до неузнаваемости.

Экспресс-макет

Если стандартный шаблон при создании диаграммы вам не понравился, вы всегда можете использовать другие варианты макетов. Для это достаточно выполнить следующие действия.

  1. Кликните на соответствующую иконку.
  2. Выберите нужный вам макет.

Необязательно сразу же вносить изменения в ваш объект. При наведении на любую иконку будет доступен предварительный просмотр.

Если найдете что-то подходящее, просто кликните на этот шаблон. Внешний вид автоматически изменится.

Стили диаграмм

Для того чтобы изменить цвет элементов, необходимо выполнить следующие шаги.

  1. Нажмите на соответствующую иконку.
  2. В результате этого вы увидите огромную палитру различных оттенков.
  1. Если хотите посмотреть, как это будет выглядеть на вашей диаграмме, просто наведите курсор на любой из цветов.
  1. Для сохранения изменений нужно кликнуть на выбранный оттенок.

Кроме этого, можно использовать готовые темы оформления. Для этого необходимо сделать несколько простых операций.

  1. Раскройте полный список вариантов у данного инструмента.
  1. Для того чтобы увидеть, как это выглядит в увеличенном виде, достаточно навести курсор на любую из иконок.
  1. Для сохранения изменений необходимо кликнуть на выбранный вариант.

Данные

Кроме этого, доступны манипуляции с отображаемой информацией. Например, можно поменять строки и столбцы местами.

После нажатия на эту кнопку вы увидите, что диаграмма стала выглядеть совсем иначе.

Данный инструмент очень помогает в том случае, если вы не можете правильно указать поля для строк и столбцов при построении данного объекта. Если вы ошиблись или результат выглядит некрасиво – нажмите на эту кнопку. Возможно, станет намного лучше и информативнее.

Если нажать еще раз, то всё вернется обратно.

Для того чтобы изменить диапазон данных в таблице для построения диаграммы, нужно кликнуть на иконку «Выбрать данные». В данном окне вы сможете

  • выбрать нужные ячейки;
  • удалить, изменить или добавить ряды;
  • отредактировать подписи горизонтальной оси.

Для сохранения изменений нужно нажать на кнопку «OK».

Как сменить тип диаграммы

Если вас не устраивает ранее выбранная категория диаграмм, вы можете изменить её в любой момент. Для этого необходимо:

  1. Нажать на указанную иконку.
  2. В появившемся окне выбрать нужный вам шаблон.
  1. При выборе любого из пунктов в левой части экрана, справа будут появляться возможные варианты для построения диаграммы.
  1. Для упрощения выбора можно навести курсор на любую из миниатюр. В результате этого вы увидите её в увеличенном размере.
  1. Для изменения типа нужно кликнуть на любой из вариантов и сохранить при помощи кнопки «OK».

Заключение

В этой статье мы пошагово рассмотрели технологию построения диаграмм в редакторе Excel. Помимо этого, было особое внимание уделено оформлению и редактированию созданных объектов, поскольку недостаточно уметь использовать только готовые варианты от разработчиков Microsoft. Вы должны учиться изменять внешний вид под свои нужды и быть оригинальными.

Если у вас что-то не получается, возможно, вы выделяете не тот элемент. Необходимо учитывать, что у каждой фигуры используются свои уникальные свойства. Если вы смогли что-то видоизменить, например, с кругом, то с текстом сделать то же самое не выйдет.

инструкция

Если у вас всё равно по каким-то причинам ничего не выходит, сколько бы вы ни старались, ниже добавлено видео, в котором вы сможете найти различные комментарии к описанным выше действиям.

Источник: https://os-helper.ru/excel/kak-postroit-diagrammu-po-dannym-tablicy.html

Создание диаграммы в Excel 2007 | Запорізька обласна універсальна наукова бібліотека

Построение диаграммы в Excel 2007 - создание и редактирование
 Чтобы создать диаграмму, выберите нужные данные, включая заголовки столбцов (январь, февраль, март) и заголовки строк (имена продавцов).
   Затем щелкните вкладку Вставка и в группе Диаграммы нажмите кнопку Гистограмма.

Можно задать другой тип диаграммы, но для отображения сравнения обычно используются гистограммы, поскольку они наиболее наглядные.
   При нажатии кнопки Гистограмма будет предложено выбрать один из доступных типов гистограмм. Щелкните Гистограмма с группировкой, первый тип диаграммы в списке Гистограмма.

Если навести мышь на тип диаграммы, появится всплывающая подсказка с его именем. В подсказке содержится также описание выделенного типа диаграммы и сведения о его использовании.

Совет. Если нужно изменить тип диаграммы после того, как она создана, щелкните кнопкой мыши в области диаграммы.

На вкладке Конструктор в разделе Работа с диаграммами в группе Тип щелкните Изменить тип диаграммы и выберите нужный тип.

Работа с диаграммами

После вставки диаграммы на лист появляется группа Работа с диаграммами с тремя вкладками: Конструктор, Макет и Формат. На этих вкладках можно найти команды, которые требуются для работы с диаграммами.

Завершив работу с диаграммой, щелкните мышью вне ее. Группа Работа с диаграммами исчезнет. Чтобы вывести ее на экран, щелкните в области диаграммы. Тогда вкладки появятся снова.

Не волнуйтесь, если команды будут отсутствовать. Выполните первый шаг, вставив диаграмму (из группы Диаграммы на вкладке Вставка) или щелкнув область существующей диаграммы. Появятся нужные команды.
 

Добавление названий

Рекомендуется добавить в диаграмму названия описательного характера, чтобы при ее изучении не приходилось гадать, к чему эта диаграмма относится.

Можно дать название самой диаграмме, а также осям диаграммы, которые служат для измерения и описания данных диаграммы. Эта диаграмма имеет две оси.

Слева находится вертикальная ось (которая также называется осью значений или осью «y»). Эта ось содержит числовую шкалу, позволяющую оценить высоту столбцов.

Месяцы показаны внизу на горизонтальной оси (называемой также осью категорий или осью «x»).

Чтобы быстро добавить названия в диаграмму, щелкните нужную диаграмму (это действие выделит ее), а затем перейдите в группу Макеты диаграмм на вкладке Конструктор. Нажмите кнопку Дополнительно, чтобы просмотреть доступные макеты. При выборе разных параметров будут показаны различные макеты, определяющие расположение элементов диаграммы.

Совет. Еще один способ задать названия — ввод их на вкладке Макет в группе Подписи. Там можно добавлять названия, щелкнув элементы Названия диаграммы и Названия осей.

Изменение внешнего вида диаграммы

Созданная диаграмма имеет стандартную цветовую палитру. С помощью стилей диаграммы можно изменить цвета диаграммы в считанные секунды.

Щелкните диаграмму. На вкладке Конструктор в группе Стили диаграмм нажмите кнопку Дополнительно, чтобы просмотреть доступные варианты, а затем выберите нужный стиль.

При применении некоторых стилей будут изменены только цвета диаграммы.

Другие стили предполагают изменение цвета и выделение столбцов, добавление цвета в область построения (область, окруженную осями) и добавление цвета для области диаграммы (то есть всей диаграммы).

Если в группе Стили диаграмм не появились нужные параметры, можно задать другие цвета, выбрав новую тему. Щелкните вкладку Разметка страницы и в группе Темы щелкните Цвета.

Если установить указатель мыши на цвете, он будет показан в области предварительного просмотра, что отличается от данных, отображаемых в стилях диаграмм. Результат выбора цвета можно увидеть до его применения, что устраняет необходимость отменять действие, если выбранный цвет не нравится.

Щелкните цвет, который хотите использовать для диаграммы.

Важно! В отличие от стиля диаграммы, цвета тем могут применяться для других элементов рабочего листа. Например, при применении темы для диаграммы также будут изменены стили таблицы и отдельных ячеек.

Форматирование названий

Если необходимо еще больше выделить название диаграммы и названия осей, то это сделать нетрудно. На вкладке Формат в группе Стили WordArt доступны многочисленные варианты оформления названий. На рисунке в название добавлена заливка текста, один из параметров этой группы, что позволяет изменить текст.

Чтобы использовать заливку текста, предварительно щелкните область названия, чтобы выделить его. Затем щелкните стрелку кнопки Заливка текста в группе Стили WordArt.

Установите указатель на нужном цвете, чтобы увидеть, как изменится название. Если цвет нравится, щелкните его.

Меню Заливка текста также содержит параметры, позволяющие применить для названия градиентную или текстурную заливку.

Другие параметры в группе Стили WordArt  — это Контур текста и Анимация, где доступны эффекты Тень, Отражение и Свечение.

Чтобы изменить шрифт, сделав его больше или меньше, или выбрать другой шрифт, щелкните , а затем перейдите в группу Шрифт.

Кроме того, можно изменить форматирование, воспользовавшись Мини-панелью. Эта панель появится в полупрозрачном виде, если выделить текст названия.

Установите на ней указатель мыши (панель станет непрозрачной), а затем выберите нужный параметр форматирования.

Добавление диаграммы в презентации PowerPoint

Когда оформление диаграммы завершено, ее можно поместить в презентацию PowerPoint, чтобы показать всем желающим. Если исходные данные диаграммы будут изменены уже после после добавления ее в PowerPoint, не расстраивайтесь. При изменении данных в Excel диаграмма в PowerPoint будет также обновлена.

Вот как это действует. Скопируйте диаграмму в Excel. Откройте PowerPoint 2007. Вставьте диаграмму в нужное место. В правом нижнем углу диаграммы появится кнопка Параметры вставки.

Щелкните ее. Будет видно, что выбран параметр Диаграмма (связь с данными Excel). Это гарантирует, что при изменении диаграммы в Excel эти изменения автоматически отразятся в PowerPoint.

Теперь все готово к показу диаграммы.

Источник: http://zounb.zp.ua/metods/ofprzab/excel/sozdanie_diagrammy_v_yexcel_2007

Как сделать диаграмму в Экселе: построить и редактировать

Построение диаграммы в Excel 2007 - создание и редактирование

Представление данных в наглядной форме диаграмм позволяет быстро оценить и проанализировать их. Как построить диаграмму в Excel? Пошаговая последовательность действий будет показана на основе приводимой ниже таблицы, показывающей помесячные доходы и налоги условного физического лица, и их соотношение в процентах.

Создание диаграмм

1. Прежде всего, необходимо выделить участок таблицы, на основе данных которого требуется построить диаграмму в эксель. В приводимом примере выделены все данные – доходы, налоги и проценты.

2. Перейти на вкладку «Вставка», и в разделе «Диаграммы» щёлкнуть желаемый вид.

3. Как видно, в разделе «Диаграммы» пользователю на выбор предлагаются разные виды диаграмм. Иконка рядом с названием визуально поясняет, как будет отображаться диаграмма выбранного вида. Если щёлкнуть любой из них, то в выпадающем списке пользователю предлагаются подвиды.

Иногда употребляют выражение «Диаграммы и графики», тем самым выделяя графический вид в отдельную категорию.

Если пользователю нужен первый из предлагаемых вариантов – гистограмма, то, вместо выполнения пп. 2 и 3, он может нажать сочетание клавиш Alt+F1.

4. При внимательном взгляде на подвиды можно заметить, что все относятся к одному из двух вариантов. Они отличаются сплошной (в зелёном прямоугольнике), или частичной (в оранжевом) закраской элементов диаграммы. Следующие два скриншота, соответствующие «зелёному» и «оранжевому» выбору, наглядно демонстрируют разницу.

Как видно, в первом случае отображаемые данные выстраиваются тремя (доходы, налоги, процент) столбиками. Второй вариант отображает их в виде закрашенных частей одного столбика.

В обоих случаях значение процента почти не видно. Это связано с тем, что на диаграммах отображается абсолютное его значение (т.е. не 14,3%, а 0,143). На фоне больших значений такое малое число еле видно.

Чтобы сделать диаграмму в экселе для данных одного типа, следует в рамках первого шага выделить именно их. На следующем скриншоте представлена диаграмма для значений процентов, которых практически не было видно на предыдущих.

Редактирование диаграмм

Закончив построение диаграмм, их можно изменить в любой момент. Одновременно с появившейся диаграммой автоматически возникает группа вкладок с общим названием «Работа с диаграммами», и происходит переход на первую из них – «Конструктор». Инструменты новых вкладок открывают широкие возможности редактирования диаграмм.

Вкладка «Конструктор»

Для отображения значений процентов часто применяется круговая диаграмма в эксель. Чтобы построить круговую диаграмму, сохранив прежние данные, нужно щёлкнуть первый слева инструмент линейки – «Изменить тип диаграммы», и выбрать желаемый подвид строки «Круговая».

На следующем скриншоте показан результат активации инструмента «Строка/Столбец», производящий взаимную замену данных на осях X и Y. Как видно, однотонная гистограмма предыдущего скриншота получила цвета, и стала гораздо привлекательней.

В разделе «Стили диаграмм» вкладки «Конструктор» можно менять стиль диаграмм. После открытия выпадающего списка этого раздела пользователю становится доступным выбор одного из 40 предлагаемых вариаций стилей. Без открытия этого списка доступно всего 4 стиля.

Очень ценен последний инструмент – «Переместить диаграмму». С его помощью диаграмму можно перенести на отдельный полноэкранный лист.

Как видно, лист с диаграммой добавляется к существовавшим листам.

Если пользователю предстоит работа по построению множества других диаграмм на основе созданной и отредактированной, то он может сохранить её для дальнейшего использования в качестве шаблона. Для этого достаточно выделить диаграмму, щёлкнуть инструмент «Сохранить как шаблон», ввести название и нажать «Сохранить». После этого запомненный шаблон будет доступен в папке «Шаблоны».

Вкладки «Макет» и «Формат»

Инструменты вкладок «Макет» и «Формат» в основном относятся к внешнему оформлению диаграммы.

Чтобы добавить название, следует щёлкнуть «Название диаграммы», выбрать один из двух предлагаемых вариантов размещения, ввести имя в строке формул, и нажать Enter.

При необходимости аналогично добавляются названия на оси диаграммы X и Y.

Инструмент «Легенда» управляет отображением и положением поясняющего текста. В данном случае это – названия месяцев. Их можно удалить или переместить влево, вверх или вниз.

Гораздо более употребителен инструмент «Подписи данных», позволяющий добавить на них числовые значения.

Если при построении диаграммы был выбран её объёмный вариант, то на вкладке «Макет» будет активен инструмент «Поворот объёмной фигуры». С его помощью можно менять угол наблюдения диаграммы.

Инструмент «Заливка фигуры» вкладки «Формат» позволяет залить любым цветом, рисунком, градиентом или текстурой фон диаграммы (как показано на скриншоте) или любой из её элементов (в данном случае – столбиков).

Для заливки соответствующего элемента он должен быть предварительно выделен.

Добавление новых данных

После создания диаграммы для одного ряда данных в некоторых случаях бывает необходимо добавить на диаграмму новые данные. Для этого сначала нужно будет выделить новый столбик – в данном случае «Налоги», и запомнить его в буфере обмена, нажав Ctrl+C. Затем щёлкнуть на диаграмме, и добавить в неё запомненные новые данные, нажав Ctrl+V. На диаграмме появится новый ряд данных «Налоги».

Новые возможности диаграмм в Excel 2013

Диаграммы рассматривались на примере широко распространённой версии Excel 2010. Так же можно работать и в Excel 2007. А вот версия 2013 года имеет ряд приятных нововведений, облегчающих работу с диаграммами:

  • в окне вставки вида диаграммы введён её предварительный просмотр в дополнение к маленькой иконке;
  • в окне вставки вида появился новый тип – «Комбинированная», сочетающий несколько видов;
  • в окне вставки вида появилась страница «Рекомендуемые диаграммы», которые версия 2013 г. советует, проанализировав выделенные исходные данные;
  • вместо вкладки «Макет» используются три новые кнопки – «Элементы диаграммы», «Стили диаграмм» и «Фильтры диаграммы», назначение которых ясно из названий;
  • настройка дизайна элементов диаграммы производится посредством удобной правой панели вместо диалогового окна;
  • подписи данных стало возможным оформлять в виде выносок и брать их прямо с листа;
  • при изменении исходных данных диаграмма плавно перетекает в новое состояние.

Источник: http://v-ofice.ru/excel/diagrammy/

Как построить график или диаграмму в Microsoft Excel 2003, 2007, 2010, 2013, строим синусойду и круговую диаграмму, линейная функция, мастер диаграмм

Построение диаграммы в Excel 2007 - создание и редактирование

Диаграммы и графики в MS Excel (входит в состав офисного пакета MS Office) служат для графического отображения данных, что более наглядно с точки зрения пользователя. С помощью диаграмм удобно наблюдать за динамикой изменений значений исследуемых величин, проводить сравнения различных данных, представление графической зависимости одних величин от других.

Чтение и оценка большого количества данных, которые визуализированы с помощью графиков и диаграмм значительно упрощается. Эксель располагает эффективным многофункциональным инструментом для этой визуализации, благодаря которому можно построить диаграммы и графики разнообразных типов и назначений. Просто незаменим в аналитических исследованиях.

На рисунке видим стандартный график зависимости в Excel, на нём показаны и подписаны основные элементы.

На данный момент используются версии приложения 2003, 2007, 2010, 2013, 2016. Процессы построения графиков и диаграмм в них имеют некоторые отличия, прежде всего в интерфейсе. Основные из них будут указываться ниже.

Как построить график в эксель

Excel поддерживает различные типы графиков для наиболее понятного и полного отображения информации. Графики строятся по точкам, которые соединяются отрезками. Чем больше точек, тем меньше искажений в графике, тем более плавно изменяется функция в динамике.

Чтобы создать график (как и диаграмму) в MS Excel нужно прежде всего ввести числовые данные на лист, на основании которых он будет построен. Обычно для графика достаточно двух столбцов, один из которых будет использоваться для оси X (аргумента), второй – для Y (функции) – это может быть выражено формулой или просто перечнем зависимых от аргумента данных.

Выделите диапазон данных.

Затем, выбрав нужный тип графика на вкладке Вставка в группе Диаграммы – нажмите Вставить график (для просмотра динамики изменений данных).

Если хотите построить график по точкам – следует взять Точечную диаграмму (если у Вас имеется 2 ряда данных, один из которых зависит от второго).

Microsoft Excel 2003 Microsoft Excel 2007 Microsoft Excel 2013


График можно разместить, как на одном листе с данными, так и на отдельном.

  Как обрезать фото онлайн бесплатно?

Как построить диаграмму

Аналогично графикам, диаграммы строятся на основе данных в столбцах таблицы, но для некоторых видов (круговые, кольцевые, пузырьковые и др.) нужно, чтобы данные располагались определенным образом. Чтобы построить диаграмму нужно перейти во вкладку Диаграммы. Для примера рассмотрим, как сделать круговую.

Для такой диаграммы один столбец – это метки данных, второй – сам числовой ряд данных.

Выделите диапазон ячеек с метками и данными. Затем Вставка, нажать Диаграммы и выбрать соответствующий Вашим требованиям тип диаграммы (в нашем случае Круговая).

Автоматически создастся диаграмма, которую при необходимости Вы сможете изменить в свойствах по своему усмотрению. Изменить можно стиль, макет, подписи, оси, фон и множество других настроек.

Диаграммы кругового типа демонстрируют пропорции частей относительно чего-то целого и представляются в виде совокупности секторов, входящих в состав круга с отображением соответствующих значений. Это очень полезно, когда требуется сравнить некоторые данные по отношению к суммарному значению.

Строим синусойду

Предположим Вам нужно построить график функции представляющий собой синусоиду. Для этого потребуется ввести данные синусов углов.

Чтоб посчитать значения синусов, нужно в первую ячейку ряда данных Sin ввести формулу = SIN(РАДИАН(A3)), где A3 – соответствующий аргумент. После чего столбец растянуть за правый нижний угол. Получим искомый диапазон значений.

Далее строим график, нажимая Вставка, График, таким же образом как и до этого. 

Как видим получившийся график не в достаточной мере похож на синусоиду. Для более красивой синусоидальной зависимости нужно ввести большее количество значений углов (аргументов) и чем больше, тем лучше.

Как добавить название к диаграмме

Если захотите изменить название, сделать его более понятным, или удалить его вовсе, то потребуется проделать следующие действия.

В версии Excel 2003 нужно кликнуть в любом месте этой диаграммы, после чего увидите панель Работа с диаграммами, со вкладками Макет, Формат и Конструктор.

В группе Макет/Подписи выберите Название диаграммы. Измените нужные Вам параметры.

  Как создать загрузочную флешку (USB-диск) Windows 10

Название можно связывать с какой-либо ячейкой таблицы, отметив ссылку на неё. Связанное значение названия автоматически изменяется при его изменении в таблице.

Как настроить оси и добавить названия

Помимо остальных функция у Вас есть возможность настраивать оси – масштаб, промежутки между категориями и значениями. Можно добавить деления на оси и указать значения расстояний между ними, добавить и отформатировать названия осей, настроить отображение или скрыть сетку.

Что касается настроек названия, подписей, осей и прочих в Office 2013, то там это сделать еще проще и удобнее: достаточно пары кликов по изменяемым визуальным компонентам и использования привязанного к ним контекстного меню.

Добавляем или изменяем легенду

Благодаря легенде на графике определяется принадлежность параметра к тому или иному столбцу.

В диаграммах эксель имеется опция настройки легенды – изменения месторасположения, отобразить её или скрыть.

Перейдите во вкладку Конструктор/Выбрать данные для версии 2003 или в контекстном меню Выбрать данные для версии 2013.

Откроется окно выбора источника данных, в котором можно изменить диапазон используемых данных, изменить подписи осей, и элементов легенды (ряды), параметры для каждого ряда в отдельности.

Как видим для построения функции в экселе обязательно наличие двух факторов – табличная и графическая части. Приложение MS Excel офисного пакета обладает прекрасным элементом визуального представления табличных данных в виде графиков и диаграмм, который можно успешно использовать для множества задач.

Источник: http://composs.ru/postroit-grafik-v-eksele/

Поделиться:
Нет комментариев

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.