Добавляем строку в таблице в Word через контекстное меню

Содержание

Как в Ворде добавить строку в таблице

Добавляем строку в таблице в Word через контекстное меню

Оформление таблиц в вордовском документе требуется достаточно часто. Например, при составлении отчетов в официальных документах, либо при написании каких-либо научных работ, типа курсовых, рефератов и т.д. Поэтому в нашей статье мы расскажем об одном из пунктов редактирования таблиц, а именно – как в Ворде добавить строку в таблице?

Создаем таблицу в Ворде

Для начала мы разберем и напомним вам, как можно создать таблицу в вордовском документе. Для начала открываем документ, где нам необходимо создать таблицу. После ставим курсор в ту часть страницы, где планируется разместить таблицу. Далее, в меню ищем раздел «Таблица».

Пользователям версии Ворде новее 2010 года необходимо найти раздел «Вставка», а далее выбрать пункт «Таблица». Ворд предложит вам создать автоматически, просто указав необходимое количество столбцов и строк. Максимальный размер 10х8.

Принцип работы достаточно прост – Вы просто надо провести курсором по квадратикам, а редактор Word автоматически сформирует таблицу, исходя из выбранного вами количества строк и столбцов.

Как в Word добавить строку в таблице: вариант для версии 2007 года

Итак, что требуется сделать пользователю, если ему необходимо вставить дополнительную строку, между 3 и 4 строками? Достаточно выполнить несколько шагов:

  1. Для начала требуется выделить нужное количество строк. Включая и третью строку.
  2. Делаем мышкой правый щелчок.
  3. После выбираем пункт под названием «Вставить».
  4. Выбираем пункт «Вставить строки снизу».

Все вышеуказанные действия показаны на рисунке ниже:

Результат всей работы будет выглядеть следующим образом:

Добавляем строку в таблицу в Word 2003

Итак, для начала пользователь должен выделить 2 и 3 строку в таблице. Далее заходим в меню «Таблица», где следующим шагом выбираем пункт под названием «Вставить». Далее пользователь выбираем пункт «Строки ниже». Если все шаги были сделаны правильно, то в таблице появятся новые строчки.

Как в Ворде добавить строку в таблице: способ № 2

Добавить строчки в таблицу, расположенной в документе, можно и при помощи меню, которое появляется на экране при нажатии правой кнопки на мышке.

Если таблице, размещенной в вордовском документе, требуется добавить две или три строки (или больше), то пользователь должен выделить нужное количество строк в таблице, а затем выбрать один из пунктов. После выполнения этих действий добавится в таблицу сразу несколько строк.

Если пользователь выберет пункт под названием «Вставить ячейки», то на экране появится окно с названием «Добавление ячеек», где пользователь сможет выбрать вставку строк «Со сдвигом вниз» или добавление целой строки.

Добавляем строчку сверху или снизу

Для начала нужно щелкнуть ячейку, именно в том месте, где требуется добавить строчку. Далее, в пункте «Работа с таблицами», что расположен на вкладке Макет необходимо выбрать одно из действий.

Например, если требуется добавить строчку над выделенной ячейкой, в пункте «Строки и столбцы» жмем на кнопку «Вставить сверху».

А вот если нужно добавить строчку под выделенной ячейкой, пользователь должен в разделе «Строки и столбцы» нажать на кнопку с названием «Вставить снизу».

Как добавить строку в программе для Мас?

Чтобы добавить строку пользователю требуется щелкнуть в том месте таблицы, где необходимо добавить строчку. После этого переходим во вкладку под названием «Макет». Она расположена рядом с вкладкой «Конструктор таблиц» на панели инструментов.

Далее пользователь должен воспользоваться командой «Вставить сверху» или «Вставить снизу», чтобы добавить строчку в таблицу. А вот команды «Вставить слева» или «Вставить справа» используются для того, чтобы добавить в таблицу столбцов.

Важно отметить, что этот вариант работы применим для Ворда 2011 года.

Добавляем строку в таблицу в Ворде 2016 года

Для того, чтобы добавить еще одну строку в таблице пользователю необходимо выбрать столбец или ячейку в таблице, а затем открыть вкладку под названием «Макет таблицы». Далее, в разделе под названием «Строки и столбцы» необходимо щелкнуть на необходимый пункт.

А вот чтобы удалить столбец в таблице, требуется открыть вкладку под названием «Макет таблицы», а затем, в разделе «Строки и столбцы» требуется нажать пункт «Удаление», а после выбрать пункт «Удалить столбцы».

Мы надеемся, что наша статья, рассказывающая как в Ворде добавить строку в таблице, помогла вам разобраться в этом вопросе. Как вы уже поняли, в этом нет ничего сложного, главное – это четко следовать указанному алгоритму действий. Дерзайте и у вас все обязательно получится!

Вам понравилась статья?

Наши авторы уже более 10 лет пишут для студентов курсовые, дипломы, контрольные и другие виды учебных работ и они отлично в них разбираются. Если Вам тоже надо выполнить курсовую работу, то оформляйте заказ и мы оценим его в течение 10 минут! Заказать работу Узнать цену

Источник: http://ru.solverbook.com/stati/kursovye-raboty/kak-v-vorde-dobavit-stroku-v-tablice/

Как вставить/добавить новые/пустые строки в Excel?

Добавляем строку в таблице в Word через контекстное меню

Одними из наиболее часто используемых действий при работе с таблицами в Excel являются добавление и удаление строк вообще и пустых строк в частности. Рассмотрим механизмы добавления и удаления пустых строк в таблицах.

Вставка одной пустой строки в таблицу Excel

Добавить новую строку стандартными средствами Excel можно следующим образом: правой кнопкой мыши кликнуть на номере строки, над которой нужно вставить новую строку и выбрать в контекстном меню пункт «Вставить»

При этом, если какие-то данные в таблице были отформатированы (изменены шрифты, изменены цвета, установлены заливки ячеек), то после добавления новой строки появится кнопка «Параметры добавления», раскрыв которую можно выбрать для новой строки один из трех пунктов «Форматировать как сверху», «Форматировать как снизу» и «Очистить формат».

Вставить пустую строку можно также и через кнопки на панели инструментов. Для этого выделите строку, над которой нужно вставить новую пустую строку. После этого зайдите на вкладку «», в группу «Ячейки» и раскройте меню кнопки «Вставить», выберите пункт «Вставить строки на лист».

Добавление нескольких пустых строк в таблицу Excel

Для того, чтобы вставить несколько новых строк в документ, необходимо выделить строку, выше которой нужно добавить новые строки, и не отпуская левой кнопки мыши выделить столько строк, сколько нужно вставить.

После того как строки выделены, необходимо щелкнуть правой кнопкой мыши на выделенном участке листа и из контекстного меню выбрать пункт «Вставить», либо воспользоваться кнопками во вкладках ленты, аналогично тому, как это описано в предыдущем пункте.

Как вставить/добавить заданное количество пустых/новых строк в определенные места?

Стандартными средствами Excel такую задачу решить можно не всегда, но не будем забывать про то, что существует такой мощный инструмент как VBA, позволяющий автоматизировать повторяющиеся однотипные действия. По инструкции устанавливается в приложение Excel надстройка для вставки пустых строк, которая предоставляет следующие возможности:

1. Выбор искомого значения, которым могут являться пустые ячейки, непустые ячейки, ячейки с заданным цветом заливки, ячейки с заданным числом, а также ячейки с заданным текстом (быквы, символы);

2. вставка заданного количества пустых строк как выше, так и ниже строк с искомым значением;

3. вставка новых строк ниже каждой второй, третьей, пятой, n-ной строки выбранного диапазона (шаг задается пользователем);

4. вставлять пустые строки при каждой смене значения в заданном столбце;

5. вставлять пустые строки между заполненными (после каждой заполненной ячейки в столбце с заданным номером);

6. выбор диапазонов для вставки строк, предусмотрено несколько режимов:

а) используемый диапазон листа — диапазон активного листа, включающий в себя все ячейки, находящиеся между первой заполненной и последней заполненной ячейкой;

б) используемые диапазоны — отличается от предыдущего режима тем, что обработка данных производится в используемом диапазоне каждого листа рабочей книги;

в) диапазон листа — диапазон, который выберет пользователь;

г) диапазоны листов — это одноименные диапазоны на всех листа рабочей книги.

*Внимательно выбирайте диапазон для получения желаемого результата!

7. выбор необходимых условий для значений ячеек.

Для числовых значений: равно/не равно, больше/не больше, меньше/не меньше.

Для текстовых значений: совпадает/не совпадает, содержит/не содержит, начинается/не начинается, заканчивается/не заканчивается.

видео по работе с надстройкой

надстройка (макрос) для добавления пустых строк в зависимости от условий и значений ячеек

Программа выполняет проверку всех ячеек заданного диапазона и при выполнении выбранного условия вставляет нужное пользователю количество пустых строк над/под строкой (на выбор), содержащей ячейку с заданным значением.

На выбор пользователя представлено множество условий для значений ячеек, с помощью которых можно определить места для вставки новых строк, а также предоставлен выбор диапазонов для обработки данных.

Для большей гибкости поиск ячеек с нужными значениями можно осуществлять раздельно, как по текстовым значениям ячеек, так и по числовым. Предусмотрен также поиск как пустых, так и непустых ячеек.

 Этот макрос позволяет также добавлять новые строки в заданном количестве в каждую n-ую строку выбранного диапазона. Если, к примеру, вставить по две пустые строки ниже каждой второй строки диапазона А2:А24, т ополучим следующий результат:

Удаление пустых строк

Удаление строк в таблицах Excel уже рассматривалось на страницах этого сайта, удаление же пустых строк является частным случаем удаления строк, замечу также что удаление пустых строк, как собственно и их вставку, можно производить программно, при помощи макроса (надстройки). Обо всем этом можно прочитать подробнее.

Источник: http://macros-vba.ru/nadstrojki/excel/105-kak-vstavit-dobavit-udalit-novye-pustye-stroki

Как добавить строку в таблице Excel: все способы

Добавляем строку в таблице в Word через контекстное меню

В наше время многие люди пользуются Экселем. Но при этом не все знают, как добавить строку в его таблице. С одной стороны, это может показаться очень простым действием. Но с другой – здесь очень много своих «подводных камней». Давайте рассмотрим различные случаи.

Начало работы

Первым делом нужно создать какую-нибудь таблицу в Excel. Для этого необходимо выполнить следующие действия.

  1. Выделите любую область. Сделайте левый клик мыши в произвольную точку листа и не отпуская пальца потяните правее и вниз.
  1. Нажмите на вкладке «» на иконку «Границы». Затем в выпадающем меню выберите пункт «Все границы».
  1. В результате этого у вас появится небольшая таблица. Можно также использовать готовые шаблоны.
  1. Заполните её любыми значениями.

Для наглядности дальнейших шагов в заполнении были использованы цифровые значения.

При помощи контекстного меню

Для того чтобы вставить строку, необходимо сделать следующее.

  1. Переместите курсор в любое место. Сделайте правый клик мыши.
  1. В появившемся меню кликаем на пункт «Вставить…».
  1. В результате этого вы увидите несколько вариантов:
    • ячейки, со сдвигом вправо;
    • со сдвигом вниз;
    • строку;
    • столбец.
  1. Выберите третий пункт и затем нажмите на кнопку «OK».
  1. Благодаря этому у вас появится новый пустой горизонтальный ряд.

Но как быть, если вам нужна новая строка не по всей ширине таблицы? В этом случае всё немного сложнее.

  1. Выделите одну ячейку и заново вызовите точно такое же меню. Только на этот раз выбираем второй пункт. Завершаем действие кнопкой «OK».
  1. В результате этого появится пустая область. То есть новая ячейка вставлена между строк и столбцов именно в том месте, где вы были до вызова контекстного меню.

Для того чтобы вставить не один пустой элемент, а два и более, необходимо выделять равно такое же количество.

  1. Повторяем описанные выше действия по добавлению ячеек. Благодаря этому будет добавлена строка с 3 элементами. Именно столько и было выделено вначале перед вызовом меню.

Обратите внимание на то, что при вставке именно «строки» не важно, в каком столбце вы находитесь. Новый горизонтальный ряд будет добавлен по всей ширине листа. При этом могут быть затронуты и другие таблицы!

Работа с несколькими таблицами

Представим, что у нас их 2.

Как и было сказано выше, результат вставки целого ряда приведет к нарушению внешнего вида соседней таблицы, поскольку разрыв появится и там.

Для того чтобы сохранить внешний облик других элементов, необходимо добавлять новые строки через ячейки. При этом предварительно выделяя весь горизонтальный ряд только одной таблицы.

Результат будет следующим.

Всё, что было справа, осталось точно таким же.

Через панель инструментов

Получить тот же самый эффект можно и через другое меню. Для этого нужно сделать следующее.

  1. Перейдите на вкладку «» и кликните на кнопку «Вставить».
  1. В результате этого появится следующее меню.
  1. Для вставки строк нажмите на соответствующий пункт.
  1. Сразу после этого будет добавлен еще один ряд, а всё остальное окажется внизу.

Данный способ более удобен, так как приходится совершать меньше действий.

  1. Теперь попробуйте нажать на пункт «Вставить ячейки».
  1. Вы увидите точно такие же варианты, которые появлялись через контекстное меню.

Вызвать данное меню можно при помощи горячих клавиш Ctrl+Shift+=. Об этом нам сообщает Excel, если работать через верхнюю панель.

Добавление без меню

Если вы выделите несколько ячеек и наведете курсор на угол, то заметите, что его внешний вид меняется.

Если сделать левый клик мыши и потянуть вниз, то можно увидеть следующее.

Последний ряд будет продублирован. Если бы он был пустой, то вы получили бы еще несколько таких же горизонтальных элементов.

Так же стоит обратить внимание на то, что, если написать любой текст после таблицы, этот элемент автоматически скопирует оформление вышестоящей ячейки.

Заключение

Благодаря несложным действиям, которые были описаны выше, вы сможете вставить новые строки:

  • в начале;
  • посередине;
  • в конце таблицы (в самом низу).

Данные методы подходят для Excel 2007 и выше.

инструкция

Ниже прилагается ролик, в котором показаны дополнительные комментарии. Он будет интересен тем, у кого остались какие-нибудь вопросы.

Источник: https://os-helper.ru/excel/kak-dobavit-stroku-v-eksele.html

Урок по создание таблицы в текстовом редакторе Word

Добавляем строку в таблице в Word через контекстное меню

Создать таблицу в Microsoft Word, не сложно. Однако, почему-то, многие пользователи пытаются вставить в документ Word таблицы Excel! Но, в Microsoft Word есть свои таблицы! Вы, быстро и красиво можете вставить их на страницу документа! Как это сделать?

Вставка таблицы в версии Word 2010 и выше

Курсор мыши ставим на странице в то место, где нужно вставить таблицу. Переходим на вкладку Вставка нажимаем кнопку Таблица.

Первый способ

Рис. 1

В открывшемся окошке проводим курсором мыши по сетке и выбираем нужное количество ячеек в таблице. При этом в документе будет отображаться таблица с указанным количеством ячеек.

Пока вы не кликнули левой кнопкой мыши, ее размеры можно менять, просто передвигая курсор в области 1 (рис. 1) Выбрав нужные размеры, закрепите их кликом левой кнопки мыши. И таблица будет вставлена в документ.

Если вам необходимо большее количество строк и столбцов, то их можно будет добавить позже или воспользуйтесь способом 2.

Второй способ

В меню Таблица выбираем команду Вставить таблицу (выделено оранжевой рамкой)

Рис. 2

Перед вами откроется окно Вставка таблицы.

Рис. 3

В этом окне нужно ввести Число столбцов и Число строк будущей таблицы. После того, как укажете число столбцов и число строк — нажимаете ОК

Таблица появится на странице:

Рис. 4

Третий способ

В меню Таблица выбираем команду Нарисовать таблицу (на рис.2). Курсор примет вид карандаша и вы можете им нарисовать таблицу уже на ваш вкус.

Рис. 5

Все указанные способы доступны и в других версиях Microsoft Word. Небольшое отличие есть в старой версии Word 2003. Там вызов осуществляется так:

В Word 2003 (Word XP), в меню Таблица (на рис. 6 обведено красным карандашом) выбираем: Вставить ==>Таблица (подчеркнуто красным карандашом).

Рис. 6

Изменение таблиц

Вы можете изменить размер таблицы, потянув за квадратик в правом нижнем углу таблицы (обведен синим карандашом на рис.4). Можете выделить всю таблицу, щелкнув по квадратику в левом верхнем углу таблицы (обведено красным карандашом).

Но, чаще придется делать действия над одной строкой, или столбцом.

Как выделить столбец? Подводите курсор мыши над таблицей, поближе к верхнему краю таблицы. Как только курсор превратится в маленькую черную стрелку (рис.

7), нажимаете на кнопку мыши и весь столбец под этой стрелкой выделится (станет черным).

Если вы, не отпуская левой кнопки мыши, передвинете черную стрелку вправо, или влево — будут выделяться другие столбцы, стоящие рядом. Отпустите кнопку — столбцы останутся выделенными.

Рис. 7

Теперь вы можете делать над текстом, находящимся в выделенной колонке, все действия, которые мы рассмотрели на уроке Форматирование текста в Word — можете изменить выравнивание текста в столбце (по центру, вправо, влево), можете изменить цвет, размер шрифта и т. д.

Но, чтобы были наглядно видны результаты ваших действий, заполните, сначала, таблицу. После этого потренируйтесь, отработайте навыки работы с таблицами ms Word.

Рис. 8

Выделять колонки-столбцы мы научились. А, как же выделять строки в таблице, спросите вы.

Это тоже не сложно. Подводите курсор мыши слева от таблицы. Как только он превратится в стрелку, направленную вправо, на таблицу, нажимаете левую кнопку мыши, Тут же выделится строка, на которую указывает стрелка (см. рис. 8).

Если вы теперь, не отпуская кнопки мыши, поведете курсор вниз, то будут выделяться другие строки. Отпустите кнопку — строки останутся выделенными. Вы можете отформатировать текст, находящийся в выделенных строках таблицы.

Кроме действий над текстом, находящимся в таблице, вы можете совершать действия над самими строками: удалять строки, добавлять строки, объединять выделенные ячейки и так далее. Все это можно делать через меню Работа с таблицами — Макет (см. рис 8).

Рис. 8

Заходите на вкладку Макет и выбираете нужное действие. Только предварительно не забудьте выделить строки, или столбцы, над которыми будете «издеваться».

Хотя, можно сделать проще. Выделяете строку, а потом нажимаете правую кнопку мыши. Появится контекстное меню со всеми действиями, которые вы можете сделать над строкой (см. рис 9)

Рис. 9

Обращаю внимание на то, что содержание контекстного меню разное, в зависимости от того, что вы выделили — строку, столбец, или всю таблицу. Выбираете из контекстного меню нужное действие и смотрите результат.

Таким образом вы можете отформатировать всю таблицу. Выровняйте строки или столбцы по центру, вправо или влево. Выделите текст цветом, или сделайте его жирным. Можете изменить размер шрифта и т.д. Также можете добавлять строки, или столбцы, объединять ячейки и т.д.

Рис. 10

В итоге, таблица может выглядеть как у меня, на рис. 10. А, можете сделать по другому, как вам нравится.

Перейти на страницу:

Источник: https://www.pc-pensioneru.ru/uroki-word-tablicy.htm

Как добавить пункт в контекстное меню

Добавляем строку в таблице в Word через контекстное меню

Чтобы работа с компьютером была удобной, в операционной системе Windows у каждого файла, папки или любого другого объекта есть контекстное меню. Открывается оно кликом правой кнопкой мышки по этому объекту.

Контекстное меню можно настраивать, добавляя и удаляя из него определенные пункты.

Об удалении пунктов читайте здесь. Ниже речь пойдет только об их добавлении в меню.

Чтобы добавить пункт в контекстное меню, необходимо внести изменения в системный реестр Windows. Сделать это можно путем «ручной» правки реестра или при помощи специальных программ (см. последний пункт этой статьи).

Первый способ немного сложный для новичков, но предоставляет более широкие возможности. В статье он рассмотрен максимально подробно. Для лучшего восприятия информация изложена в следующем порядке:

1. Как добавить простой пункт в контекстное меню файла, папки, Рабочего стола, значка «Компьютер» или Корзины;

2. Добавление в меню выпадающего списка из нескольких пунктов;

3. Как добавить пункт или выпадающий список только в меню файлов определенного типа.

1. Добавление в контекстное меню простого пункта

Для внесения изменений в системный реестр необходимо открыть Редактор реестра.

Кратко напомню, как работать в этом редакторе.

Чтобы открыть Редактор реестра нужно на клавиатуре нажать комбинацию клавиш Win+R, в открывшемся окне напечатать или скопировать туда с этой страницы слово regedit, после чего нажать клавишу Enter.

Окно Редактора реестра разделено на две части по вертикали. В левой его части находится проводник. Он предназначен для навигации. Например, чтобы открыть ветку реестра HKEY_CLASSES_ROOT/*/shell, необходимо в проводнике Редактора двойным кликом мышки открыть сначала раздел «HKEY_CLASSES_ROOT», в нем найти и таким же способом открыть раздел «*», а в нем — раздел «shell».

Подробно порядок работы в Редакторе реестра описан в этой статье.

Чтобы добавить пункт в контекстное меню файла, папки, Рабочего стола или любого другого объекта, необходимо открыть Редактор реестра и в соответствующей ветке создать новый раздел с необходимыми параметрами, в которых прописать название пункта, исполняемую им функцию и др.

Непосредственно о порядке создания этого раздела речь пойдет немного ниже. Сначала давайте разберемся, в какой именно ветке реестра его нужно создавать.

Все зависит от того, в контекстное меню какого объекта необходимо добавить пункт. Если это контекстное меню:

• файлов — радел нужно создавать в ветке:

HKEY_CLASSES_ROOT/*/shell

• папок — в ветке:

HKEY_CLASSES_ROOT\Folder\shell

• запоминающих устройств (диски, флешки и др.) — в ветке:

HKEY_CLASSES_ROOT\Drive\shell

• значка «Компьютер» — в ветке:

HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell

• Рабочего стола — в ветке:

HKEY_CLASSES_ROOT\DesktopBackground\Shell

• значка «Корзина» — в ветке:

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\shell

Теперь добавим новый пункт в контекстное меню одного из указанных объектов.

Например, в меню файлов добавим пункт, который будет открывать их в браузере Mozilla Firefox.

Порядок действий:

1. В Редакторе реестра открыть соответствующую ветку.

Поскольку в нашем примере пункт должен появиться в контекстном меню файлов, открываем ветку HKEY_CLASSES_ROOT/*/shell;

2. Создать в ней новый раздел.

С этой целью в проводнике Редактора необходимо щелкнуть правой кнопкой мышки по папке «shell», и в открывшемся списке выбрать «Создать» — «Раздел» (см. изображение). Назвать этот раздел можно как угодно, используя латинские буквы и цифры. Я назвал «Open to Firefox».

3. В новом разделе создать строковый параметр с названием MUIVerb (он определяет название пункта контекстного меню).

Для этого в проводнике Редактора реестра нужно щелкнуть правой кнопкой мышки по созданному разделу (который я назвал «Open to Firefox») и в появившемся списке выбрать «Создать» ⇒ «Строковый параметр» (см. изображение).

Новый строковый параметр появится в правой части Редактора реестра. Нужно присвоить ему название MUIVerb, после чего дважды щелкнуть по нему левой кнопкой мышки.

Затем в нижнем поле открывшегося окна указать словосочетание, которое будет отображаться в контекстном меню, и нажать кнопку ОК. Я написал «Открыть в Firefox» (см. изображение).

Кроме параметра MUIVerb, в созданный раздел аналогичным образом можно добавить еще несколько параметров (не обязательно). В частности:

• строковый параметр с названием Position. Он определяет, в каком месте контекстного меню будет находиться пункт. Ему можно присвоить одно из двух значений: Top (вверху) или Bottom (внизу). Если этот параметр не создавать, пункт будет отображаться в середине контекстного меню.

Я создал параметр Position и присвоил ему значение Bottom.

• строковый параметр с названием Icon. Он определяет, какая иконка будет отображаться в контекстном меню слева от пункта.

В значении этого параметра нужно указать путь к файлу иконки формата .ICO. Можно также указать путь к какой-нибудь программе. В таком случае будет использоваться иконка этой программы.

Поскольку создаваемый мною пункт должен открывать файл в браузере Firefox, я указал в нем путь к файлу этого браузера.

• строковый параметр Extended. Если добавить этот параметр в созданный раздел, пункт контекстного меню станет «скрытым». Чтобы он отображался, перед открытием контекстного меню нужно будет нажать и удерживать клавишу Shift.

Этому параметру не нужно присваивать никакого значения (оставить пустым).

В свой пример этот параметр я решил не добавлять.

4. В проводнике редактора реестра снова щелкнуть правой кнопкой мышки по созданному разделу (в моем случае он с названием «Open to Firefox») и в появившемся списке выбрать «Создать» ⇒ «Раздел».

В нашем разделе появится еще один раздел, которому необходимо присвоить название command.

5. Выделить раздел command в проводнике Редактора реестра (щелкнуть по нему мышкой). После этого в правой части Редактора дважды щелкнуть мышкой по параметру с названием «(По умолчанию)».

Затем в нижнем поле открывшегося окна, в поле «Значение», необходимо указать путь к программе, которая должна открываться создаваемым пунктом контекстного меню.

В моем случае пункт должен открывать файл в окне Firefox, поэтому я прописал путь к этому браузеру.

Важно. Через пробел от пути к программе я добавил метку «%1» (см. изображение). Она указывает на то, что пункт должен не просто запустить программу, но и открыть файл в ее окне (без этой метки пункт будет запускать пустое окно браузера).

Новый пункт контекстного меню создан. У меня он получился таким:

Кроме простых пунктов, в контекстное меню можно добавлять многоуровневые выпадающие списки.

Предлагаю рассмотреть порядок их создания. В качестве примера добавим в меню файлов пункт «Открыть в браузере», из которого будет выпадать список из 5 браузеров (см. изображение).

Порядок действий:

1. В соответствующем контекстном меню создать простой пункт. При наведении на него будет появляться выпадающий список. Действовать при этом нужно так, как описано выше, за исключением п.5 (раздел command создавать не нужно).

То есть, необходимо открыть соответствующую ветку реестра, создать в ней раздел и добавить в него несколько строковых параметров:

• с названием MUIVerb, в значении которого указать название пункта (обязательно);

• с названием Position и значением Bottom или Top (не обязательно);

• с названием Icon и указанием пути к файлу иконки (не обязательно);

Поскольку мне нужно создать выпадающий список в меню файлов, я:

• открыл ветку реестра HKEY_CLASSES_ROOT/*/shell ;

• создал там новый раздел (назвать его можно как угодно, я назвал spisok) ;

• в этом новом разделе создал строковый параметр с названием MUIVerb и значением «Открыть в браузере».

Кроме того, чтобы пункт находился внизу, я создал в этом разделе строковый параметр с названием Position и значением Bottom.

2. Кроме перечисленных строковых параметров, в созданном разделе нужно создать еще один строковый параметр и назвать его SubCommands. Этот параметр превращает обычный пункт контекстного меню в выпадающий список.

После создания параметра дважды щелкнуть по нему левой кнопкой мышки и в его значении указать несколько коротких названий (любых), используя латинские буквы и цифры. Количество этих названий должно соответствовать количеству пунктов в будущем выпадающем списке. Записывать их нужно через точку с запятой, без пробелов. Использование нескольких одинаковых названий не допускается.

Поскольку выпадающий список из моего примера должен включать 5 браузеров, я придумал 5 названий: raz1, raz2, raz3, raz4, raz5. Записав их через точку с запятой, я получил следующее: raz1;raz2;raz3;raz4;raz5 (см. изображение).

3. В проводнике Редактора реестра перейти в ветку

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell

В этой ветке для каждого пункта выпадающего списка необходимо создать новый раздел. Создаваемым разделам необходимо присвоить названия, которые были указаны в значении строкового параметра SubCommands (см. предыдущий пункт).

Как помните, в своем примере в параметре SubCommands я указал 5 названий: raz1, raz2, raz3, raz4, raz5. Этими названиями я и назвал 5 новосозданных разделов, см. изображение.

4. В каждом из новосозданных разделов необходимо сделать следующее:

• дважды щелкнуть левой кнопкой мышки по строковому параметру с названием «(По умолчанию)» и в открывшемся окне указать название пункта выпадающего меню (обязательно). В каждом из моих 5 разделов я указал здесь название браузера (raz1 — Firefox, raz2 — Opera, raz3 — Chrome, raz4 — Яндекс.Браузер, raz5 — Safari).

• в каждый из созданных разделов добавить строковый параметр с названием Icon (не обязательно) и указать в нем путь к иконке, которая должна отображаться в контекстном меню рядом с пунктом (точно так же, как и в случае с простым пунктом, см. выше);

• в каждом из созданных разделов создать еще один раздел и назвать его command. В разделе command дважды щелкнуть мышкой по параметру с названием «(По умолчанию)» и в открывшемся окне указать путь к программе, которую должен запускать пункт выпадающего списка.

В каждом из моих 5 разделов здесь я указал путь к соответствующему браузеру. И поскольку пункт должен не только запускать браузер, но и открывать файл в его окне, через пробел от пути я добавлял метку «%1», см. изображение.

Вот и все. В результате у меня получился выпадающий список из 5 браузеров (см. изображение выше).

3. Как добавить пункт
только в меню файлов определенного типа

Иногда возникает необходимость добавить пункт в контекстное меню не всех файлов, а только файлов определенного типа, например, файлов формата .txt или .jpeg. Давайте разберемся, как это сделать.

Выше уже говорилось, что для добавления пунктов в контекстное меню абсолютно всех файлов нужно создать соответствующие записи в ветке реестра HKEY_CLASSES_ROOT/*/shell .

Чтобы добавить пункт только в меню файлов определенного типа, необходимо добавить те же записи в другую ветку. Что это за ветка — зависит от типа файла и установленного на компьютере программного обеспечения. На каждом конкретном компьютере она будет другой. Но ее всегда можно определить самостоятельно.

Рассмотрим, как это делается, на примере файла формата .jpeg

Порядок действий:

1. В Редакторе реестра открыть раздел HKEY_CLASSES_ROOT, найти в нем папку, название которой соответствует требуемому расширению файла, и выделить ее (один раз щелкнуть по ней левой кнопкой мышки).

Учитывая, что в качестве примера был взят файл .jpeg, я нашел и выделил папку с названием «.jpeg».

2. В правой части Редактора реестра дважды щелкнуть мышкой по строковому параметру с названием «(По умолчанию)» и посмотреть, что указано в его значении. То, что там указано, является названием папки в разделе HKEY_CLASSES_ROOT, в которую необходимо перейти.

На моем компьютере в значении этого параметра указано «jpegfile». Значит, мне необходимо перейти в ветку HKEY_CLASSES_ROOT/jpegfile

3. Перейдя в указанную папку, необходимо найти в ней раздел с названием «shell». Если такого раздела там нет, его необходимо создать. Этот раздел и есть веткой реестра, в которую необходимо добавлять соответствующие записи для создания пункта контекстного меню.

В моем примере, это ветка HKEY_CLASSES_ROOT/jpegfile/shell

Новые пункты в контекстное меню можно добавлять при помощи программ. Вот названия некоторых из них:

• Context Menu Editor;

• Open++;

• ContextEdit;

• Context Menu Manager;

• SendTo Commander;

• The Right click commander;

• Mmm Free.

Источник: https://www.chaynikam.info/kak-dobavit-punkt-v-kontextnoe-menyu.html

Работаем с текстовыми процессорами

Добавляем строку в таблице в Word через контекстное меню

17.05.1999 Джордж Кэмпбелл

Меню, которое появляется после нажатия правой кнопки мыши в редакторе Word, позволяет сэкономить массу времени, так как на экран мгновенно выводятся часто используемые команды для выполнения определенной задачи.

Однако в контекстном меню может не оказаться необходимых вам команд — так, если щелкнуть правой кнопкой мыши на каком-либо слове документа, команда «Тезаурус» (Thesaurus) не появится.

Тем не менее ее можно добавить, используя следующий метод.

Word 97

  1. Выберите пункты меню «Сервис?Настройка» (Tools?Customize) и в диалоговом окне «Настройка» (Customize) отметьте закладку «Панели инструментов» (Toolbars).
  2. В списке «Панели инструментов» (Toolbars) включите опцию «Контекстные меню» (Shortcut Menus) для вывода на экран соответствующей панели инструментов.
  3. Выберите необходимую категорию для отображения списка меню, а затем то меню, которое требуется модифицировать.
  4. В диалоговом окне «Настройка» выделите закладку «Команды» (Commands), а в списке «Категории» (Categories) — необходимую категорию. Например, команда «Тезаурус» находится в категории «Сервис» (Tools), что соответствует ее расположению в меню редактора Word. Перетащите мышью команду, которую вы хотите добавить в отображаемое на экране контекстное меню. Нажмите кнопку «Закрыть» (Close). Примечание. Чтобы удалить любую команду, выведите ее мышью за пределы меню.

Word 6 и 7

  1. Выберите пункты «Сервис?Настройка» (Tools?Customize), а затем в диалоговом окне «Настройка» (Customize) — закладку «Меню» (Menus).
  2. В списке «Изменить меню» (Change What Menu) найдите и отметьте меню, которое хотите модифицировать.
  3. Получив список категорий с именами типа «Файл» (File) и «Формат» (Format), выделите категорию команды, которую собираетесь добавить. Если вы ее не находите, то укажите «Все команды» (All Commands).
  4. В списке «Команды» (Commands) отыщите и выделите команду, которую будете добавлять. Если необходимо поместить команду в определенную позицию контекстного меню, то откройте список «Положение в меню» (Position on Menu) и выберите одну из первых трех. Нажмите кнопки «Добавить» (Add) и «Закрыть» (Close). Примечание. Чтобы удалить пункт из контекстного меню, выделите команду в списке «Положение в меню» и отметьте кнопку «Удалить» (Remove).

Очистка текста электронной почты

Когда вы вставляете текст из сообщения электронной почты или загружаете текстовый файл в документ Word, то получаете странное разбиение текста на строки. Проблема заключается в том, что Word помещает символы абзаца в конец каждой вставленной строки.

(Для отображения всех невидимых символов нажмите на основной панели инструментов кнопку «Непечатаемые символы».

) Хотя в Word 97 команда «Формат?Автоформат» (Format?AutoFormat) и позволяет несколько очистить текст от нежелательных символов, она может также добавить ненужные стили заголовков для отформатированного текста.

Чтобы преобразовать сообщения электронной почты в простой текст (без форматирования), я создал макрос для Word 97, 6 и 7. Выполните представленную ниже процедуру, чтобы создать макрос для вашей версии редактора, а если у вас нет желания вводить все эти длинные и непонятные команды, загрузите его с Web-узла PC World-FileWorld.

Word 97

  1. Выберите пункты меню «Сервис?Макрос?Макросы» (Tools? Macro?Macros).
  2. В диалоговом окне «Макрос» (Macros) в поле «Имя» (Macro Name) введите fixmail и нажмите кнопку «Создать» (Create).
  3. Аккуратно между строками Sub fixmail() и End Sub введите текст макроса, включая все символы пунктуации. Примечание. Там, где в тексте макроса встречаются символы «##», нажмите один раз клавишу пробела. Не вводите ##.
  4. Выберите пункт меню «Файл?Сохранить Normal» (File? Save Normal), а затем «Файл?Закрыть и вернуться в Microsoft Word» (File?Close and Return to Microsoft Word).

Sub fixmail()dowhat = wdFindStopIf Selection.Type = wdSelectionIP ThenSelection.HomeKey Unit:=wdStorydowhat = wdFindContinueEnd IfSelection.Find.ClearFormattingSelection.Find.Replacement.ClearFormattingWith Selection.Find.Text = ?p?.Replacement.Text = [email protected]@@?.Forward = True.Wrap = dowhatEnd WithSelection.Find.

Execute Replace:=wdReplaceAllWith Selection.Find.Text = [email protected]@@@@@?.Replacement.Text = ?pp?.Forward = True.Wrap = dowhatEnd WithSelection.Find.Execute Replace:=wdReplaceAllWith Selection.Find.Text = [email protected]@@?.Replacement.Text = ?##?.Forward = True.Wrap = dowhatEnd WithSelection.Find.

Execute Replace:=wdReplaceAllEnd Sub

Word 6 и 7

  1. Выберите пункты меню «Сервис?Макрос» (Tools?Macro).
  2. В диалоговом окне «Макрос» (Macro) в поле «Имя» (Macro Name) наберите fixmail и нажмите кнопку «Создать» (Create).
  3. Аккуратно введите между строками Sub MAIN и End Sub указанный ниже текст макроса, включая все символы пунктуации. Примечание. Прежде чем нажать , введите полностью строки, начинающиеся с EditReplace и заканчивающиеся .Wrap = dowhat. Там, где в тексте макроса встречаются символы «##», нажмите один раз клавишу пробела. Не вводите ##.
  4. Выберите пункты «Файл?Закрыть» (File?Close) и для сохранения внесенных изменений нажмите «Да» (Yes).

Sub MAINdowhat = 1If SelType() = 2 Then dowhat = 0End IfEditReplace .Find = ?p?, .Replace = [email protected]@@?, .Direction = 0, .ReplaceAll, .Wrap = dowhatEditReplace .Find = [email protected]@@@@@?, .Replace = ?pp?, .Direction = 0, .ReplaceAll, .Wrap = dowhatEditReplace .Find = [email protected]@@?, .Replace = ?##?, .Direction = 0, .ReplaceAll, .Wrap = dowhatEnd Sub

С помощью данного макроса можно переформатировать и весь документ, и выделенный фрагмент текста. Выберите пункт меню «Сервис?Макрос?Макросы» (Word 97) или «Сервис?Макрос» (Word 6 или 7), в списке «Имя» (Macro Name) выделите fixmail и нажмите кнопку «Выполнить» (Run). Примечание.

Данные макросы лучше работают с текстом, состоящим из абзацев, разделенных пустой строкой, — такое форматирование используется для большинства сообщений электронной почты.

Если ваш текст включает также разделы с короткими строками в формате списка, то выделите блоки с обычным форматированием и выполните макрос для каждого из них.

Стилизованное переформатирование

Чтобы предварительно посмотреть, что получится в результате применения различных стилей к существующему документу Word, вам потребуется «Библиотека стилей» (Style Gallery), которая, в отличие от простого форматирования текста, позволяет выявить разницу между различными способами форматирования писем, заметок или отчетов, построенных на основе имеющихся в редакторе Word шаблонов.

  1. Откройте в Word документ и выберите пункты «Формат?Библиотека стилей» (Format?Style Gallery).
  2. В секции «Просмотреть» включите опцию «Документ» (Document), а в списке «Шаблон» (Template) задайте один из шаблонов. В окне предварительного просмотра вы увидите, как будет выглядеть документ после его применения.
  3. Выбрав подходящий шаблон, для его использования и возврата в окно редактирования документа нажмите ОК.

Совет. Для просмотра документа до его создания в каком-либо стиле можно обратиться к «Библиотеке стилей» и выбрать опцию «Пример» (Example) или «Образцы стилей» (Style Samples). Чтобы создать документ в таком же стиле, как из выбранного шаблона, нажмите ОК.

Выравнивание нумерованных списков

При создании нумерованного списка в Word номера строк выровнены по левому краю. Мне не нравится, что в случае, когда он содержит более девяти пунктов, единица в цифре 10 и каждой следующей строке всегда выровнена по левому краю. Есть ли какой-нибудь способ выравнивания цифр по правому краю?

Нестор Мендиола, г. Сан-Диего

Большинство людей разделяют ваше недовольство по поводу используемого по умолчанию стиля выравнивания цифр. К счастью, это можно исправить.

Word 97

  1. До создания нумерованного списка или после выделения существующего выберите пункты меню «Формат?Список» (Format?Bullets and Numbering).
  2. Если необходимо, в диалоговом окне «Список» (Bullets and Numbering) щелкните мышью по закладке «Нумерованный» (Numbered) и выделите нужный вам стиль создания списка.
  3. Нажмите кнопку «Изменить» (Customize).
  4. В ниспадающем списке «Положение номера» (Number position) диалогового окна «Изменение нумерованного списка» (Customize Numbered List) задайте «По правому краю» (Right).

Word 6 и 7.

  1. До создания нумерованного списка или после выделения существующего выберите пункты меню «Формат?Список» (Format?Bullets and Numbering).
  2. Если необходимо, в диалоговом окне «Список» (Bullets and Numbering) выделите закладку «Нумерованный» (Numbered) и задайте один из стилей создания списка.
  3. Нажмите кнопку «Изменить» (Modify).
  4. В ниспадающем списке «Выравнивание текста списка» (Alignment of List Text) раздела «Положение номера» (Number Position) диалогового окна «Изменение нумерованного списка» (Modify Numbered List) укажите «По правому краю» (Right). Для завершения процедуры нажмите ОК.

Полноэкранный режим просмотра Word

Полноэкранный режим просмотра редактора Word, для перехода в который необходимо указать пункты «Вид?Во весь экран» (View?Full Screen), убирает с экрана все «лишнее» и оставляет больше места для текста.

Чтобы в таком режиме произвести форматирование текста, выделите его и щелкните правой кнопкой мыши для отображения контекстного меню. Можно также воспользоваться сочетанием клавиш — например, +I для курсивного или +B для полужирного начертания.

Для доступа к меню Word нажмите , а затем клавишу с соответствующей буквой, в частности, для меню «Файл» (File) укажите +Ф (+F), а для меню «Правка» (Edit) — +П (+E).

Чтобы возвратиться к обычному режиму редактирования, нажмите (в Word 6 или более поздних версиях) или кнопку «Вернуть обычный режим» (Close) на панели инструментов «Во весь экран» (Full Screen) (Word 7 и 97).

1502

Источник: https://www.osp.ru/pcworld/1999/05/160410

Поделиться:
Нет комментариев

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.